Home | News | Documentation | Download

Problem Installing TMVA

Hi,
I’m having problems with the installation of the TMVA. I have followed all the steps appearing in the user guide that you provide but apparently I am doing something wrong what it is probable cause I’m new with Root.
I’m using the last version of Ubuntu 16.04 and the last version of ROOT 6.09/02
Here the steps I’ve followed and where I find the error:

  1. Obtain Root from Github:

Desktop/TMVA$ git clone http://root.cern.ch/git/root.git MyRoot
Desktop/TMVA$ cd MyRoot/build

  1. Installing Root:

~/MyRoot/build$ cmake --all -D:PATH=~/Desktop/TMVA/MyRoot …CMAKE_INSTALL_PREFIX
~/MyRoot/build$ make –j4
~/MyRoot/build$ sudo make install

Until here everything works fine and ROOT works without problems.

  1. Intalling TMVA

~/MyRoot$ git checkout v5-34-00-patches
~/MyRoot$ cd tmva
~/MyRoot$ >make # compile and build the library lib/libTMVA.1.so

Here it’s where the problems appears. The User guide and the QuickStart say that lib/libTMVA.1.so should be created however instead I get an error I can understand and that I haven’t seen in the Forums.

Here the screenshot of the error:

Obviously I can’t follow with the next steps that would be:

~/MyRoot/tmva> cd test
~/ MyRoot/tmva/test> source setup.sh #for c-shell family: source setup.csh

Could you please help to get this done? I would like to start using the use-cases as soon as possible.

Thank you

Hi,

TMVA is part of ROOT since a long while.
I propose you checkout ROOT as you did and:

git clone http://root.cern.ch/git/root.git MyRoot
cd MyRoot;git checkout v6-09-02
cd -
mkdir build
cd build
cmake ../MyRoot
make -j 5

TMVA is built by default.

Cheers,
D

1 Like

Thanks a lot for the answer.

Could you please tell me the steps I should follow to use the macro of TMVA (par example TMVAClassification.C) because I can install Root without a problem but I can’t run the TMVA macros.

I went to the folder tutorial where It’s the file (“TMVAClassification.C”) and what I get is:

I think I’m missing something about how I have to run the TMVA examples and I guess I’ve mixed up the quickStart the User Guide etc…

So If you can give a hint, I’d very grateful.

Thanks!!

Hi,
the error message is telling you that you don’t have curl.
Please install it with “apt-get install curl”

Cheers,
D

1 Like

It worked fine finally!!!

Many thanks for answer so fast.

Cheers.

glad you solved this!

Dear Experts,
I followed the same procedure. But I am getting the attached error every time I try to install it.
Could you please suggest me one solution for it.

Thanks

Hi, we’re glad to help. However, in general it is better to start a new thread rather than reviving old ones.

Ensure that you are building the latest version of root, TMVA is included in the distribution and does not need to be downloaded separately. (I mention this since the presence of the TMVA/macros folder in your screenshot, it is not used in newer versions).

If this does not solve your issue, please open a new thread and provide more details on what you are doing and your environment (version of root, commads you execute, etc.).

Cheers,
Kim

Thanks, I will.

Regards