Problem Installing root_v5.34.38 in Ubuntu 16.04 LTS ppc64le

Dear Rooters

I am facing problem in installing root_v5.34.38 on server power machine installed with Ubuntu 16.04.5 LTS (GNU/Linux 4.4.0-131-generic ppc64le). The errors are as follows:

**config.guess timestamp = 2009-11-20**

**uname -m = ppc64le**
**uname -r = 4.4.0-131-generic**
**uname -s = Linux**
**uname -v = #157-Ubuntu SMP Thu Jul 12 15:47:54 UTC 2018**

**/usr/bin/uname -p = **
**/bin/uname -X     = **

**hostinfo               = **
**/bin/universe          = **
**/usr/bin/arch -k       = **
**/bin/arch              = **
**/usr/bin/oslevel       = **
**/usr/convex/getsysinfo = **

**UNAME_MACHINE = ppc64le**
**UNAME_RELEASE = 4.4.0-131-generic**
**UNAME_SYSTEM  = Linux**
**UNAME_VERSION = #157-Ubuntu SMP Thu Jul 12 15:47:54 UTC 2018**
**configure: error: cannot guess build type; you must specify one**
**bin/rmkdepend -R -fcint/reflex/src/BuilderContainer.d -Y -w 1000 -- -pipe -Wall -m64 -fPIC -fsigned-char -DR__ppc64 -I/usr/X11/include -Iinclude    -pthread -D__cplusplus -- /cern/root/cint/reflex/src/BuilderContainer.cxx**
**bin/rmkdepend -R -fcint/reflex/src/OnDemandBuilder.d -Y -w 1000 -- -pipe -Wall -m64 -fPIC -fsigned-char -DR__ppc64 -I/usr/X11/include -Iinclude    -pthread -D__cplusplus -- /cern/root/cint/reflex/src/OnDemandBuilder.cxx**
**g++ -O -pipe -Wall -m64 -fPIC -fsigned-char -DR__ppc64 -I/usr/X11/include -Iinclude    -pthread -o cint/reflex/src/BuilderContainer.o -c /cern/root/cint/reflex/src/BuilderContainer.cxx**
**g++ -O -pipe -Wall -m64 -fPIC -fsigned-char -DR__ppc64 -I/usr/X11/include -Iinclude    -pthread -o cint/reflex/src/OnDemandBuilder.o -c /cern/root/cint/reflex/src/OnDemandBuilder.cxx**
**make[1]: Entering directory '/cern/root/core/lzma/src/xz-5.0.3/src/liblzma'**
**make[1]: *** No targets specified and no makefile found.  Stop.**
**make[1]: Leaving directory '/cern/root/core/lzma/src/xz-5.0.3/src/liblzma'**
**/cern/root/core/lzma/ recipe for target 'core/lzma/src/xz-5.0.3/src/liblzma/.libs/liblzma.a' failed**
**make: *** [core/lzma/src/xz-5.0.3/src/liblzma/.libs/liblzma.a] Error 2**
**make: *** Waiting for unfinished jobs....**
**100   115    0   115    0     0    107      0 --:--:--  0:00:01 --:--:--   107**
**100  203k    0  203k    0     0  83933      0 --:--:--  0:00:02 --:--:--  602k**
***** Building core/lz4/src/lz4-1.7.5/lib/liblz4.a...**
**make[1]: Entering directory '/cern/root/core/lz4/src/lz4-1.7.5'**
**make[2]: Entering directory '/cern/root/core/lz4/src/lz4-1.7.5/lib'**
**compiling static library**
**compiling dynamic library 1.7.5**
**creating versioned links**
**make[2]: Leaving directory '/cern/root/core/lz4/src/lz4-1.7.5/lib'**
**make[1]: Leaving directory '/cern/root/core/lz4/src/lz4-1.7.5'**

I face the same problem with other sources also (v5.34.30, etc.)
Needs help in urgent. Anyone is kind enough to sort out this problem.


ROOT Version: Not Provided
Platform: Not Provided
Compiler: Not Provided


try to configure with --disable-lzma. And even better: use ROOT 6.14 - that should work out of the box.


Dear Axel

Thank you for your suggestions. I tried configure with --disable-lzma, but did not work out. Then I switched over to ROOT 6.14. After trying various earlier versions ROOT 6.14.02 got installed it seems. I tried to run basic macro and it executes it properly.
Thanks again



This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.