Problem Installing ROOT on Windows 7

Hi all.

I am not sure if this is a bug or if I am too “untalented” to install ROOT. Well, I can bet it is the latter.

I have a Windows 7 (64bit) machine with the latest version of Cygwin (CYGWIN_NT-6.1) and Visual Studio Express (12.0) - as demanded on the prerequisites page - installed not 20min ago where I now want
to install the latest recommended ROOT version (Pro, version 5.34/15).
I want to install ROOT in the cygwin environment according to the instructions given here,, but I already fail at step 2.
It says, that one should execute the command ./configure --help in the root directory, but I
get the following error message:

./configure: Zeile 31: $'\r': Kommando nicht gefunden. ./configure: Zeile 37: $'\r': Kommando nicht gefunden. ./configure: Zeile 111: $'\r': Kommando nicht gefunden. ./configure: Zeile 114: Syntaxfehler beim unerwarteten Wort `$'do\r'' '/configure: Zeile 114: `for flag in "$@"; do

Looking into the file “configure” on row (Zeile) 31 I find an empty line. It is the empty line after the
command "host = " in row 30.

Thank you for your help and best wishes,

Hi heico,

It looks like your git client is not properly configured. It should keep the right line endings (LF vs CR/LF). So you should configure it such as the “autocrlf” git option is set as “input” (“autocrlf = input” in your gitconfig file)
And BTW, you must use Visual Studio 11 (2012), since there is a bug in version 12 (2013), preventing to build ROOT from source (there is a bug report filled at the Microsoft web site)

Or use one of the prebuilt binary :wink:

Cheers, Bertrand.

Hi Bertrand.

Thank you for your reply. You were right, the git wasn’t configured correctly.
However, not it is, and when I try to execute “./configure win64gcc” I get
the following error message.

$ ./configure win64gcc Checking for source directory ... /home/Conni/root Configuring for win64gcc Checking for GNU Make version >= 3.80 ... ok Checking for C compiler ... gcc Checking for C++ compiler ... g++ Checking for linker (LD) ... no LD compiler $(ROOT_SRCDIR)/build/unix/ found configure: Linker MUST be installed See

Now, I have looked through the bunch of different packages for cygwin, installed all interpreter and library packages, and everything which had a “gcc” or “64” in its name :stuck_out_tongue:
Still it doesnt work, the linker is missing, but where to get it?
Or is that the consequence of using Visual Studio Express 2013 12.0 ? (as I am not very fond of the idea to uninstall the whole studio and install 11.0 anew. I first wanna try “easier” ways - if possible)

Thank you and best wishes,

Hi heico,

OK, so it seems you mix (or misunderstood) the two options you have on Windows:

[ul][li]Using (building) ROOT in cygwin/gcc and X11 with the complete cygwin environment (like working on Linux)[/li]
[li]Using (building) ROOT in native Windows environment, using Visual Studio[/li][/ul]So before going further, could you tell me which way you want to use ROOT?

Cheers, Bertrand.

Hi Bertrand.

I prefer the former one.
Did I misunderstand the prerequisites website where it says that one
should have cygwin and VS installed?


[quote=“heico”]I prefer the former one.
Did I misunderstand the prerequisites website where it says that one
should have cygwin and VS installed?
[/quote]For a long time, cygwin (but no gcc, and no X11) was mandatory to build ROOT (because of the configure/make scripts). But now one can use CMake… (it is much simpler)
If you look at the Installing ROOT from Source page, you can see “Two build methods”, explaining how to build ROOT with CMake:

[quote]Follow these instructions to install ROOT using CMake, or read below on using the “./configure;make” method.
Cheers, Bertrand.


I got a problem while building root under win7.

I was following the steps on
and succeded up to the “make” command.

Eventhough the files, e.g. Makefile.win32gcc, exist, I get the error:
Makefile:51: /config/Makefile.win32gcc: No such file or directory

see .txt for Terminal in/output.

I have cygwin64 installed
and the Pro, version 5.34/17 of root in the folder C:\install

input in cagwin64 Terminal:
cd /cygdrive/c
tar xzvf /cygdrive/c/install/root…tar.gz
cd root
./configure win32gcc --build=debug
make -j2 (<-- errors)

I spend a lot of time to solve that, but as I am quite new to these kind of thing it did not work out. Hopefully there is someone here who can help me.

root build.txt (11.2 KB)


and the Pro, version 5.34/17 of root in the folder C:\install[/b][/quote]Could you tell me which file you downloaded? (exact full name)
And did you try without “export ROOTSYS=$PWD”?

Cheers, Bertrand.

Hi Heico,

the exact filename is root_v5.34.14.source.tar.gz

just now I downloaded the newer version root_v5.34.17.source.tar.gz from
still same problem

I tried different types. with and without export …
tried changing the value ROOT_SRCDIR = /cygdrive/c/root in the makefile … didn’t help
Makefile:52: /cygdrive/c/root/config/Makefile.win32gcc: No such file or directory

should I try older versions? though I think the error could be more profound …

BTW, why not using the native version (do you really need cygwin/gcc)?

that’s somewhat a good question … your talking about the .msi files for root/vc++
it’s some what tough to navigate on the website, so I didn’t see this version

either way after removing cygwin and setting it up anew the problem was gone
so thanks