Problem in running v5.30.02 - font and problems

I am still somewhat new to Linux. I am running 64-bit Centos 6 (RHEL) with v.5.30.02 and I cannot get ROOT to run. I keep getting the following error message:

[root@localhost lib]# root Couldn't find font "-adobe-helvetica-medium-r-*-*-10-*-*-*-*-*-iso8859-1", trying "fixed". Please fix your system so helvetica can be found, this font typically is in the rpm (or pkg equivalent) package XFree86-[75,100]dpi-fonts or fonts-xorg-[75,100]dpi. /usr/local/bin/root.exe: error while loading shared libraries: cannot open shared object file: No such file or directory

To install ROOT, I used:

./configure linuxx8664gcc --prefix=/usr/local make install

I’ve seen this error a few other places in the forum but the solutions do not appear to be posted anywhere. If anyone has any ideas, please let me know. I tried installing the fonts but I have a feeling there is something more fundamentally wrong because of the issue with I verified that the exists.

The suggestion below was offered in another post, but I do not know how to check the LD_LIBRARY_PATH.

Please help,

Trying doing:

cd /usr/local find . -name "libCore*" -print

This tells you were you put libCore. (Probably /usr/local/root/lib)

Then do:

This tells you where you told root where you put libCore. The command printenv prints all current environment variables.

If they are different you can get the error you got. In /usr/local/root/bin there should be a macro thisroot.csh. If you are using cshell, you want to source that macro to set up the environment variables. If you are using bash, you want to source

There’s enough here to get what you need via google, but if you have issues post more.


Well, I tried setting the environment variable for LD_LIBRARY_PATH but every time I restart terminal, the environment variable disappears (as well as the edit to PATH). I looked around online and tried a few things, but nothing made the LD_LIBRARY_PATH a persistent variable.

I decided to try the bin/ and just to set it up to run this each time I try to run root. This more or less resolves the issue with the libCore, but the font problem with helvetica is still there. I setup root in the directory /usr/local as opposed to /usr/local/root. Could this cause some trouble?

I’m not running on CentOS anymore, btw. Instead I’m running Ubuntu 11.10 as a virtual dual boot. The partitions are virtual but I’m not actually running Ubuntu in a window of Windows 7 Professional or anything like that. If anyone has experience with root in this kind of setup, please lend me whatever advice you can (thanks in advance!).

Now that root is working (to some extent), this problem has become more of a hobby than a priority.
Thanks for your help,