Problem in running main92 in PYTHIA8219

Dear Exports,

      I am trying to make tree in PYTHIA8 , so, first I run main92 but I am facing this type of problem.I tried but don't get rid off.Will you suggest me something.

environment:ubuntu 15.10, PYTHIA8219, root version -v5-34-30

[AliEnv] baidya@baidya:~/pythia8219/examples$ make main92
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:/home/baidya/alice/root/v5-34-30/inst/lib;
/home/baidya/alice/root/v5-34-30/inst/bin/rootcint -f -c -I…/include main92.h main92LinkDef.h
Error: Symbol Dl_info is not defined in current scope /usr/include/dlfcn.h:94:
Error: Missing whitespace at or after line 189.
Error: Unexpected end of file (G__fgetspace():2) /usr/include/dlfcn.h:191:
Report: Unrecognized string ‘__END_DECLS’ ignored /usr/include/dlfcn.h:192:
Warning: Error occurred during reading source files
Warning: Error occurred during dictionary source generation
!!!Removing main92Dct.h !!!
Error: /home/baidya/alice/root/v5-34-30/inst/bin/rootcint: error loading headers…
Makefile:128: recipe for target ‘main92’ failed
make: *** [main92] Error 1

Thanking you in advance for your support.


It looks to me to be more a problem with your pythia installation than ROOT. I would try sending the question to the Pythia support forum

Best Regards


This problem with the latest versions of Pythia8 and CINT was fixed (avoided) in recent patch releases of 5.34. Please use a more modern one such as 5.34/36

Hi all

I have exactly the same problem. Indeed, I saw in the pythia website ( … usage.html) that this seems to be a know problem (take a look to the “error notice” section). However, even when I add the mentioned lines to the PythiaStdlib.h file, I still get the same error. Or am I missing something?

Thanks for your help!


I have installed root 5-34-36 as recommended above, but the problem is still there. Any other advice?



Hi Lizardo,

Please try with ROOT 6 (where it should just work); we won’t fix ROOT 5 anymore.

Cheers, Axel.