Problem in getting line histogram

It seems this is a very trivial problem but I haven’t yet been able to solve it. I am trying to plot a histogram after filling it from the entries in the TTree along with adding weight to each entry while filling it [histo->Fill(xx,weight)]. But the moment I use this command, the default file histogram vanishes and I get error bars. I used all the options given in the link ( for 1D histograms(example:histo->Draw(“L”) or histo->Draw(“l”)) but still I get the same error bar histogram. I am facing this problem only when I add weight to each event (i.e not when using histo->Fill(xx)).
Any suggestions on how to overcome this problem?
Thanking you in advance!

Are you sure you tried all the available options, in particular did you try h->Draw("hist")?

1 Like

Yes, this option works!(histo->Draw(“hist”)). I had only tried the options given in the table "Options for 1D histograms or 2D histograms"

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.