Problem generating/using dictionary

Hi there,
apologies if there is an answer to my question already on the forum somewhere; I had a look through and couldn’t find anything specifically relevant. I would also appreciate some guidance since I am new to this task!

My situation is:

  1. I have written a class and I want the dynamic library generated during compilation to be loaded into PyRoot - This I can do.
  2. I want to make my class useable in PyRoot so I am attempting to generate a dictionary using rootcint embedded in a Makefile - this is where I run into problems!

My Makefile is as follows:

[code]FASTJETCFLAGS=(shell fastjet-config --cxxflags) FASTJETLIBS=(shell fastjet-config --libs)

fastJetClass: MyDict.cxx fastJetClass.cxx
g++ -O3 (FASTJETCFLAGS) (FASTJETLIBS) …/libfjplugins.a fastJetClass.cxx fastJetClass.h MyDict.cxx MyDict.h AKTVR.hh …/CoreJetAlgorithm/ …/CoreJetAlgorithm/CoreJetAlgorithm.hh -o -shared -fPIC


MyDict.cxx: fastJetClass.h LinkDef.h
rootcint -f @ -c (FASTJETCFLAGS) -p $^

rm *.o fastJetClass

When I run the make using this Makefile, compilation fails and I get the attached output.

I would be very grateful if someone could help me out with this!
Many thanks in advance
makeOutput.txt (6.4 KB)

Instead of “g++ -O3 … -fPIC” put:

Thank you very much Pepe, yes that compiled fine and I can instantiate my class in (Py)Root.