Problem during installation on Fedora Core 3 64bit


I just tried to install root4.03/02 with a gcc-3.4.2 compiler on
a Fedora Core 3 64bit architecture.

the ./configure command runs smoothly
but the following ‘make’

aborts with this error message:

… (a long list of code…)
g++ -shared -Wl,-soname, -O2 -o lib/ gl/src/TGLKernel.o gl/src/TViewerOpenGL.o gl/src/TArcBall.o gl/src/TGLRenderArea.o gl/src/TGLSceneObject.o gl/src/TGLRender.o gl/src/TGLCamera.o gl/src/TGLEditor.o gl/src/TGLFrustum.o gl/src/TX11GL.o gl/src/gl2ps.o gl/src/G__GL.o -lGLU -lGL -L/usr/X11R6/lib64 -lX11 -lXext -lXmu -lXi -lm
/usr/bin/ld: gl/src/gl2ps.o: relocation R_X86_64_32 against `a local symbol’ can not be used when making a shared object; recompile with -fPIC
gl/src/gl2ps.o: could not read symbols: Bad value
collect2: ld returned 1 exit status
make: *** [lib/] Error 1

Can somebody tell me what’s wrong? I already filed through the root talk, but couldn’t find any posting explaining a similar problem.

Thank you for your help.

Greets Onkelbaer

This problem is fixed in the CVS version


Dear Rene,

thanks for your fast answer!
Could you please let me know as well where to get this ROOT version?
As it seems for FC3 there is only an RPM Version for i386 available, demanding an i386 Version of several libs such as “glibc”, that would then co-exist with my x86_64 glibc Version and that coexistance causes severe problems on my system. I have had that problem before.

Out of all these different versions, which one is the right one for me?

Thanks for your help and assistance.

Greets Onkelbaer

I’m sorry, problem already solved, misunderstood your posting. Looks fine now.

Greets Onkelbaer