Home | News | Documentation | Download

Problem compiling v6-04-00-patches


Hello, I am tryting to compile git branch v6-04-00-patches on linux manjaro, gcc 7.3.0. I am not using any special flag, just cmake ../souce. I really have to use that branch, I can’t use a newer one (e.g. no problem compiling v6-12-06)

[ 39%] Built target rootcling_tmp
[ 39%] Generating G__IO.cxx, ../../lib/libRIO.rootmap
In file included from input_line_4:2:
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/7.3.0/../../../../include/c++/7.3.0/stdlib.h:36:
In file included from /usr/lib/gcc/x86_64-pc-linux-gnu/7.3.0/../../../../include/c++/7.3.0/cstdlib:77:
/usr/lib/gcc/x86_64-pc-linux-gnu/7.3.0/../../../../include/c++/7.3.0/bits/std_abs.h:102:3: error: support for type '__float128' is not yet implemented
  abs(__float128 __x)
/usr/lib/gcc/x86_64-pc-linux-gnu/7.3.0/../../../../include/c++/7.3.0/bits/std_abs.h:102:18: error: support for type '__float128' is not yet implemented
  abs(__float128 __x)
Error: Error loading the default header files.
make[2]: *** [io/io/CMakeFiles/G__IO.dir/build.make:91: io/io/G__IO.cxx] Error 1
make[1]: *** [CMakeFiles/Makefile2:15095: io/io/CMakeFiles/G__IO.dir/all] Error 2
make: *** [Makefile:152: all] Error 2


gcc v7.3 was released long after v6.04 and contains changes that are incompatible …

If you need to use v6.04, you may have to also use an older version of the compiler.


Thank you. Do you know if there is any flag I can use to compile with gcc 7?


Not really. The error seems to be coming from rootcling which means that it is the embedded version of Clang that is not supporting __float128. You could look in the cstdlib header file to see if their a flag to avoid include the declaration with __float128.