Problem compiling root WSL 1 Ubuntu 22.04

Please read tips for efficient and successful posting and posting code

_ROOT Version:6.26/02
Platform: WSL1 Ubuntu 22.04 LTS
Compiler: gcc

Dear Root community,

I am trying to compile the last stable version from git of ROOT 6.26/02 on WSL 1 with Ubuntu 22.04.

I got it with the command

git clone --branch latest-stable --depth=1 root_src

My cmake is

cmake  -DCMAKE_INSTALL_PREFIX=../root_install_linux/ -DCMAKE_CXX_STANDARD=17 -Dqt5web=ON -Dwebgui=ON -Droot7=ON ../root_src/

I tried to compile with 8 cpu:

cmake --build . --target install -j8

I get an error like this one without any further information:

[ 58%] Copying /mnt/d/Libraries/ROOT/root_src/ui5/fitpanel/view/FitPanel.view.xml
[ 58%] Copying /mnt/d/Libraries/ROOT/root_src/ui5/panel/Controller.js
[ 58%] Copying /mnt/d/Libraries/ROOT/root_src/ui5/panel/panel.html
[ 58%] Built target move_artifacts
-- XROOTD install command succeeded.  See also /mnt/d/Libraries/ROOT/root_build_linux/builtins/xrootd/XROOTD-prefix/src/XROOTD-stamp/XROOTD-install-*.log
[ 58%] Completed 'XROOTD'
[ 58%] Built target XROOTD
make: *** [Makefile:156: all] Error 2

If I compile in single thread, it goes further but I get the following problem:

[ 92%] Generating G__Rint.cxx, ../../lib/Rint.pcm
Scanning dependencies of target G__Rint
[ 92%] Building CXX object core/rint/CMakeFiles/G__Rint.dir/G__Rint.cxx.o
[ 92%] Built target G__Rint
[ 92%] Building CXX object core/rint/CMakeFiles/Rint.dir/src/TRint.cxx.o
[ 92%] Building CXX object core/rint/CMakeFiles/Rint.dir/src/TTabCom.cxx.o
[ 92%] Linking CXX shared library ../../lib/
[ 92%] Built target Rint
[ 92%] Building CXX object main/CMakeFiles/root.exe.dir/src/rmain.cxx.o
[ 92%] Linking CXX executable ../bin/root.exe
[ 92%] Built target root.exe
[ 92%] Generating G__Geom.cxx, ../../lib/Geom.pcm
<<< cling interactive line includer >>>: fatal error: module file '/mnt/d/Libraries/ROOT/root_build_linux/lib/Rint.pcm' is out of date and needs to be rebuilt: could not read module signature
<<< cling interactive line includer >>>: note: imported by module 'MathCore' in '/mnt/d/Libraries/ROOT/root_build_linux/lib/MathCore.pcm'
Error: Module 'MathCore.pcm' failed to load.
Error: Module 'Hist.pcm' failed to load.
Error: Error loading the default rootcling header files.
gmake[2]: *** [geom/geom/CMakeFiles/G__Geom.dir/build.make:191: geom/geom/G__Geom.cxx] Error 1
gmake[1]: *** [CMakeFiles/Makefile2:34284: geom/geom/CMakeFiles/G__Geom.dir/all] Error 2
gmake: *** [Makefile:156: all] Error 2

Any idea of what is happening?
Thanks in advance.

Compiling on WSL2 instead of WSL1 worked but I find it strange…


@bellenot might have an idea of what the problem can be?

No idea, but since it works with WS2 works, I suppose it’s all good now

I am getting the same error with ubuntu 22.04 as real OS and VM.


(there may have been a missing dependency in the CMakeFiles)

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.