Problem compiling root on AIX 7.1

Hi, thanks in advance for you support and your hard work,
I’m trying to compile root root-6.05.02 on AIX 7.1 TL3 using gcc. I think I’ve installed all the prereck I run
cmake /root/root-6.05.02/

and I get a list of warning … but exit was
– Generating done
– Build files have been written to: /

and then I run:
cmake --build .

but I get this:

Scanning dependencies of target LLVMSupport
[ 0%] Building CXX object interpreter/llvm/src/lib/Support/CMakeFiles/LLVMSupport.dir/APFloat.cpp.o
In file included from /root/root-6.05.02/interpreter/llvm/src/include/llvm/ADT/Hashing.h:49:0,
from /root/root-6.05.02/interpreter/llvm/src/lib/Support/APFloat.cpp:18:
/root/root-6.05.02/interpreter/llvm/src/include/llvm/Support/Host.h:23:28: fatal error: machine/endian.h: No such file or directory
#include <machine/endian.h>

I don’t know what I’m missing.


Pier Fortunato Bottan

Hi Pier Fortunato,

unfortunately at the moment ROOT 6 is not compliant with big endian systems.
We have only stable builds on ppcle+ubuntu platforms.


Grazie Danilo,

powerpc processors are Big Endian so I think you meant Big Endian is not supported :slight_smile:
Thanks again!


Hi Pier,

thanks for the clarification: sure :slight_smile:
The only power architecture we support presently is power8 which offers little endian support.