Problem compiling a class : undefined symbol... bug maybe?

I made a class TDN which inherits from a class made by a MakeClass. It compiled fine for sometime but since a couple of days I cannot compile it using :
TDN.cxx++ in ROOT it complains of :

dlopen error: /home/camsonne/cvs/dvcs/Extraction/./ undefined symbol: _Z8GetEntryi

I tried to clean up the code and well it looks like if I compile the code with g++ the compiler does not complain and ROOT loads the library without problem.

I tried to add a function GetEntry by hand and this seems to solve the problem :
see the part of program in TDN2.cxx
//Uncomment this function to get it to compile in CINT !!!
// Int_t GetEntry(int entry)
// {
// return entry;
// }

if you uncomment it and launch ROOT again it should compile the class correctly

so maybe a TDN2:: is missing somewhere…

I’m using root 5.02/00 on Redhat 9 with gcc 3.2.2


testTDN.tar.gz (8.42 KB)

At line 767 of TDN2.cxx you are redeclaring the function GetEntry !

Also note that the signature of TTree::GetEntry is
Long64_t TTree::GetEntry(Long64_t entry)


Oops my mistake, I indeed missed it, though I looked many times for GetEntry… danger of the copy and paste from the header…
Well I’m sorry for the bothering and thanks again !