Problem about Installing ROOT on Ubuntu

Hello, I’m a ROOT novice. I tried to install the root_v6.08.06.Linux-ubuntu16-x86_64-gcc5.4 version on ubuntu 16.04 as the file INSTALL under root/README folder says but I failed. I need some help on installing ROOT. Thanks in advance. My steps were as follow:

1.Get the sources.
I download root_v6.08.06.Linux-ubuntu16-x86_64-gcc5.4.tar.gz on and extracted it. And then I wanted to access Git repository but it showed as follow:

~$ tar -zxf root_v6.08.06.Linux-ubuntu16-x86_64-gcc5.4.tar.gz

~$ cd root

~/root$ git tag -l
fatal: Not a git repository (or any of the parent directories): .git

~/root$ git checkout -b v6-08-06 v6-08-06
fatal: Not a git repository (or any of the parent directories): .git

The command lines are from the site

2.Getting ready for building
I installed and upgraded the necessary and recommended prerequisites tools such as cmake, gcc, g++.
Gcc and g++ version are 5.4.0. Cmake version is 3.5.1

  1. Choosing installation method
    I tried to use location independent build method and type commands as follow:

~$ mkdir ROOT

~$ cd ROOT/

~/ROOT$ cmake …/root
CMake Error: The source directory “/home/zhang/root” does not appear to contain CMakeLists.txt.
Specify --help for usage, or press the help button on the CMake GUI.

That moment, I thought I failed to install ROOT. I don’t know what steps went wrong. It showed that I lacked a git repository and CMakelist.txt. Subdirectories and file are listed as follow:
{aclocal} {cmake}, {emacs}, {fonts}, {icons}, {lib}, {macros}, {README}, {tmva},
{bin}, {config}, {etc}, {geom}, {include}, {LICENSE}, {man}, {test}, {tutorials}.

What should I do to make sure I install ROOT successfully?

Thanks in advance.

You downloaded the “binary distribution” which is ready for your system.
Simply unpack it:
~$ tar -zxf root_v*.Linux-ubuntu16-x86_64-gcc5.4.tar.gz
and start to use it:
~$ source ./root/bin/
~$ root

1 Like

Thanks for your reply.
I typed the command.But it showed as follow:
~$ ls
root root_v6.08.06.Linux-ubuntu16-x86_64-gcc5.4.tar.gz

~$ source ./root/bin/

~$ root
bash: /home/zhang/root/bin/root: cannot execute binary file: Exec format error

P.S. “zhang” is my username.

What should I do?

When you execute “cat /etc/issue”, do you get “Ubuntu 16.04.2 LTS”?
When you execute “uname -m”, do you get “x86_64”?

Try maybe to do a “cleanup”:
~$ rm -rf root
~$ tar -zxf root_v*.Linux-ubuntu16-x86_64-gcc5.4.tar.gz

I got these information this time.
~$ cat /etc/issue
Ubuntu 16.04.2 LTS \n \l

~$ uname -m

And then I cleaned up and unpacked tar file again. It also showed that “can not execute binary file: Exec format error.”

By the way, I am installing root on vitual machine on Vmware. Does it matter?

Thanks a lot for your help.

Thanks a lot !
I successfully ran ROOT in Ubuntu on hard disk, not on virtual machine.
And I have another question. Are there any differences on functions between source distribution and binary distribution? Am I required to install any other git repository? Or anything is ready when using root.

Note: “i686” is a 32-bit system while “x86_64” is a 64-bit one (that is why you got “cannot execute binary file: Exec format error”).
You need a “x86_64” system if you want to use the “binary distribution” provided by the ROOT team (you do not need to rebuild ROOT, unless you need some features which are missing in this particular “binary distribution”, but can be “switched on” when you build your own ROOT version).
If you want ROOT on your “i686” system, you will need to compile it yourself using the “source code”.


Thank you very much ! My problem has been solved.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.