PoofEvent error with ROOT v6.09.01 - tutorials

Hi all,

I am currently tying some analysis in PROOF, ROOT v.6.09.01 (gcc-5.4.0, linuxx8664-fc24 ).
When I’m testing the PROOF tutorials, I’m getting the following error message after testing the ProofEvent functionality of the runProof(“event”,“lite://”) macro.

Info in TProofLite::SetQueryRunning: starting query: 1
Info in TProofQueryResult::SetRunning: nwrks: 4
Info in TUnixSystem::ACLiC: creating shared library /home/user/Root/build-64/tutorials/proof/ProofEvent_C.so
/home/user/Root/build-64/tutorials/proof/ProofEvent_C_ACLiC_dict.o: In function ProofEvent::Process(long long)': ProofEvent_C_ACLiC_dict.cxx:(.text+0xc9): undefined reference toEvent::Build(int, int, float)’
collect2: error: ld returned 1 exit status
Error in : Compilation failed!
Error in TSelector::GetSelector: The file /home/user/Root/build-64/tutorials/proof/ProofEvent.C+ does not define a class named ProofEvent.
Error in TProofLite::CopyMacroToCache: could not create a selector from /home/user/Root/build-64/tutorials/proof/ProofEvent.C+
Info in TProofQueryResult::RecordEnd: output list cloned successfully!
Lite-0: all output objects have been merged

The strange thing is that ProofSimple example is working within the same architecture.
If I switch to another architecture Root v5.34.36 (gcc-5.4.0, linuxx86-fc24) the example even the ProofEvent is working perfectly.
Could you tell what I’m missing? or is it something related with ROOT v6.09.01?

thank you
error_ProofEvent.txt (1.95 KB)

Dear myk,

I will have a look, it looks like event.par is not loaded.
Just to make sure: 6.09/01 is the master: can you be more precise on the version



G Ganis

Dear Ganis,

The command return the following result:

root [0] gROOT->GetGitCommit()
(const char *) “v6-09-01-60-g9ad1dac”

Looking forward for your answer.
Thank you


I am not able to reproduce the problem on a similar, though not exactly equal, setup (Ubuntu 16.04, gcc 5.4.0).
Looking at your log it looks like event.par is not rebuild. Can you retry by first removing the tutorial area

$ rm -fr  /tmp/user/.proof-tutorial

G Ganis

Dear Ganis,

I do not understand what is wrong with the v6.09.01.
Anyway, I have removed the user tutorial area but the problem persist, even if the Event fie is recompiled.
Please look the the attached error file.
I will try to downgrade the root version and I will let you know.
thank you
error2-ProofEvent.txt (2.7 KB)


Well, 6.09/01 is not really a tag, is a snapshot of the current master. I could not exactly figure out exactly which snapshot you have, but there are many things going on in this moment and you may expect inconsistencies, though we are trying to resolve them asap.

The test I mentioned before was done with today’s master. If you are building ROOT yourself, can you pull the latest status?
But in general, unless you really need something from the master, I suggest to use a tag; for example, the latest 6-08-04 or 6-08-02.

This said, there seems to be something wrong in the event.par used:

Info in <TPackMgr::Install>: installing /home/user/Root/build-64/tutorials/proof/event.par ...
[TFile::Cp] Total 0.00 MB       |====================| 100.00 % [0.6 MB/s]
[TFile::Cp] Total 0.01 MB       |====================| 100.00 % [146.7 MB/s]
Warning in <TPackMgr::Install>: checksums do not match:
        downloaded:     b8af6f14b8a0dab32884d782de42305b
        expected:       af81ba046682da100782fa9e7b4d4cec
building event ...

I believe this is at the origin of the problem. What do you have under


after a failure?
What do you get from

$ diff /tmp/user/.proof-tutorial/packages/event.par /home/user/Root/build-64/tutorials/proof/event.par


G Ganis

Dear Ganis,

I think I figure out the problem actually is.
I downgraded to ROOT version v6-08-00 and it generated same error but with more info (attached file).
As you can see from the error file I had another shared library libEvent.so of a different (from the original Event file) working version of Event class.
The problem was caused because the LD_LIBRARY_PATH pointed to the place where I worked to another version of Event class that generate other version of libEvent.so.

Therefore the problem was related with my LD_LIBRARY_PATH and with the fact that I used the same name of the library (for my working place) as existing one.

thank you for your support !
error3-ProofEvent.txt (4.25 KB)

Ok, I am glad that you have found it.
Thanks for reporting.

G Ganis