Please, help me!

Hi everybody.
I’m not a Unix expert and maybe my difficulties are very easy to solve. I hope somebody could help me.
I’ve got Mandrake linux 10.1 on my pc and I’ve tried to install root, but the answer is that I need x11 devel libraries. So i’ve downloaded it but I cannot install anyway. In fact when i type urpmi libxorg etc. Unix tell me that is not possible to install 'cause devel is not satisfied (libfreetype). I’m stalled at all and I don’t know what to do. I’ve searched for some
information around the net, but nobody has told me something useful. Please, could anybody help me?
Thanks anyway.

Hi Gianninnn,
see (the first half of)

Thank you so much for your answer. I’ve tried to follow what is written on the site you showed me, but when I try to install libfreetype he tells me everything is already installed. I can’t continue anyway…

Hi Gianninnn,
check what version of libxorg-x11 you have installed:

rmp -qi libxorg-x11 should show libxorg-x11-6.7.0 or 6.7.0 as the version name. If you really have the devel libs installed (check with rmp -qi libxorg-x11-devel) then you should tell us here (send the output of rmp -ql libxorg-x11-devel), because in that case root’s configure script might not have found it.

If your libxorg-x11 is older than 6.7.0, run

rpm -Uv rpm -Uv If it’s version 6.7.0 just run the second command, and if it’s newer you should get a newer devel rpm.

If you run into problems it might be better for you to post at a Mandrake forum, as this really looks like a Mandrake problem.

Thank you so much Axel. Unfortunately it doesn’t work, so I gave up and installed Mandrake 9.2. Now it’s everything ok. I have to work with root right now so I cannot waste time searching for a solution of Mandrake compatibility. Maybe in the future I’ll try again.
Thank you very much again. Bye!