PCRE Compile Error During ROOT build

Hello, I am trying to build version 6.12.06 on mac 10.15.2. I am building from the git clone with the 6.12.06 tag. I cd to the path/root/build and do:

cmake ..
cmake --build .

During the build I get:

CMake Error at /Users/naglelab/root/build/PCRE-prefix/src/PCRE-stamp/PCRE-configure-RelWithDebInfo.cmake

This yields an error log with:

configure: error: in `/Users/naglelab/root/build/PCRE-prefix/src/PCRE':
configure: error: cannot run C compiled programs.
If you meant to cross compile, use `--host'.
See `config.log' for more details

In an attempt to remedy this, I have updated xcode and the command line tools. I also did brew PCRE and tried building with builtin PCRE. To do this, I recompile with:

cmake .. -Dbuiltin_pcre=ON

I am not sure that this is really finding my installed version of PCRE because the output from this command contains:

Building pcre version 8.37 included in ROOT itself

Then build with the same build command as previously. It may be of note that the build does not restart of the beginning it starts from about 53% which is slightly before the PCRE compile step. The build crashes with the same error message.

My questions are:

  1. Is there something wrong with my configure flag that is preventing root from building with the builtin PCRE?
  2. What can I do to make PCRE configure correctly.

Thank you and let me know if more information is necessary.

Why do you want to compile ROOT 6.12.06 and not the latest version: 6.18.04? It would be easier to help you with this version.

No particular reason. I did get the 6.14 binaries to install, so I don’t know that this is worth time to solve. Let me know if you want me to retest with 6.18

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.