Path problem for root-6.14 demos

ROOT Version: 6.14.00
Platform: Ubuntu 18.04
Compiler: ccmake gcc-7.3.0

I have just compiled root 6.14 from source without any errors. It opens fine but when I try to run the demos it cannot find the path to the tutorials.
They are actually located in
But as you can see from the error below root is searching /usr/localdoc missing “/” between local and doc.
Does anyone know how I can fix this or is this a known error or have I missed something during the compile process?

root [0] .demo
root [1] Error in <TApplication::ExecuteFile>: macro demoshelp.C not found in path .:/usr/local/./root/macros:/usr/localdoc/root/tutorials/


No idea… I’ll investigate next week, but it might take some time, since I’ll need to set-up a virtual machine (I’m working on Windows), and try to reproduce the issue. Stay tuned!

Cheers, Bertrand.


Could you post here the output of those command in a ROOT session?


Cheers, Bertrand.

Thank you for looking into this Bertrand.
Here is the output:

root [0] gROOT->GetRootSys()
(const TString &) "/usr/local"[10]
root [1] gROOT->GetTutorialsDir()
(const char *) "/usr/local/./doc/root/tutorials"
root [2] gROOT->GetDataDir()
(const TString &) "/usr/local/./root"[17]
root [3] gROOT->GetDocDir()
(const TString &) "/usr/local/./doc/root"[21]
root [4] gROOT->GetTutorialsDir()
(const char *) "/usr/local/./doc/root/tutorials"

OK, thanks. I’m a bit confused, but I’ll try to reproduce it nevertheless…

Cheers, Bertrand.

I cannot reproduce it… Can I ask you how you configured and installed ROOT? What CMAKE_PREFIX did you specify (if any)?

mkdir ~/build-root
cd ~/build-root
cmake -G “Unix Makefiles” -Dbuiltin_xrootd=ON -Dcxx17=ON -DCMAKE_INSTALL_PREFIX:PATH=/usr/local -Dgnuinstall=ON ~/root-6.14.00

sudo cmake --build . --target install – -j4

Thanks. I tried (with the master) and cannot reproduce the problem. Will try again with 6.14 and let you know

Thanks for all the help Bertrand.
Maybe I’ll try installing again.

Just removed root and ran make again.
All is working perfectly.

Actually, I did notice that I had installed it using checkinstall the first time. I bet that is what messed things up.
The original command that I ran was:

sudo checkinstall -D --backup=no cmake --build . --target install – -j4

Hopefully this might help someone else if they run into the same problem.
Thanks for all your help.

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.