Offline compilation and tbb

Dear ROOT developer,
reading this post reminds me that I experienced similar problems with TBB (see this post).
I have downloaded the master branch this morning and tried to compile it on an offline computer. It is still the same as what I described in my previous post (error during downloading).
I tried to disable"builtin_tbb" but it switches on automatically.
Is it planned to implement the same behaviour as the one for LZ4?

BTW, it is not mention on the Build Prerequisites page that TBB is requireds for compiling the latest ROOT version.

Yes, it’s still a problem, and these packages are slowly being migrated to a new system. To build offline, you need -Dimt=OFF rather than -Dbuiltin_tbb=OFF, as that’s the option that needs TBB to work. The goal is to make ROOT usable offline as you suggest. For LZ4 it has already been fixed. You don’t need network anymore for that.

1 Like

Indeed, if I wirte -Dimt=OFF and -Dbuiltin_tbb=OFF, compilation succeeds

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.