Not finding TVirtualStreamerInfo

I installed ROOTv.5.26 on a relatively new OS X system with 10.6.8 and the installation went as expected except when I try to use TFile to open a ROOT file I get this error:

I check $ROOTSYS/etc/plugins/TVirtualStreamerInfo and it does exist. Scanning through the file all the environmental variables seem to be in order so I’m not sure why ROOT is failing. Any thoughts?


Which configure option did you use? What is the content of $ROOTSYS/etc/plugins ?


My only configure options were enabling python and roofit.
The contents of the $ROOTSYS/etc/plugins

[quote]ROOT@@Math@@IRootFinderMethod TGLHistPainter TProofProgressLog TVirtualGraphPainter
ROOT@@Math@@Minimizer TGLManager TProofServ TVirtualHistPainter
ROOT@@Math@@VirtualIntegrator TGPasswdDialog TSQLServer TVirtualMonitoringWriter
TAFS TGeoManagerEditor TSessionViewer TVirtualPS
TApplication TGrid TSlave TVirtualPad
TArchiveFile TGuiBuilder TSystem TVirtualPadEditor
TBrowserImp TGuiFactory TView TVirtualPadPainter
TChain TImage TViewerX3D TVirtualProofPlayer
TDataProgressDialog TImagePlugin TVirtualAuth TVirtualStreamerInfo
TDataSetManager TMinuitGraph TVirtualDragManager TVirtualTreePlayer
TFile TPaletteEditor TVirtualFFT TVirtualTreeViewer
TFileDrawMap TProof TVirtualFitter TVirtualViewer3D
TFileStager TProofMgr TVirtualGLImp TVirtualX
TFitEditor TProofProgressDialog TVirtualGeoPainter


What are the values of $ROOTSYS which root.exe otool -L `which root.exe` otool -L $ROOTSYS/lib/


I am having exactly same issue. Just tried compiling versions 5.34.01 and 5.32.04.
the ldd for root.exe and ldd for 5.32.04 for example give me the following:

[code]ldd ~/ROOT/5.32.04/bin/root.exe => /home/rowlandj/ROOT/5.32.04/lib/root/ (0x00002b1b07c43000) => /home/rowlandj/ROOT/5.32.04/lib/root/ (0x00002b1b08600000) => /home/rowlandj/ROOT/5.32.04/lib/root/ (0x00002b1b08f9a000) => /lib64/ (0x0000003f91e00000) => /usr/lib64/ (0x0000003fa2c00000) => /lib64/ (0x0000003f91a00000) => /lib64/ (0x0000003fa0000000) => /lib64/ (0x0000003f92200000) => /lib64/ (0x0000003f91600000) => /usr/lib64/ (0x0000003f92600000) => /lib64/ (0x0000003fa3000000)
/lib64/ (0x0000003f90600000)[\code]


ldd => /usr/lib64/ (0x00002b1fb7e06000) => /lib64/ (0x00002b1fb801a000) => /home/rowlandj/ROOT/5.32.04/root/lib/ (0x00002b1fb8252000) => /lib64/ (0x00002b1fb8bed000) => /usr/lib64/ (0x00002b1fb8df1000) => /lib64/ (0x00002b1fb90f1000) => /lib64/ (0x00002b1fb9375000) => /lib64/ (0x00002b1fb9583000) /lib64/ (0x0000003f90600000)

also when running make install I get a message (even though I run the configure script with --prefix=some_path option):

[code]Installing config files in /etc/root
mkdir: cannot create directory /etc/root': Permission denied cp: target/etc/root’ is not a directory[\code]

[url]Release 5.32.03 on Ubuntu 12.04
[url]Release 5.32.03 on Ubuntu 12.04