Not compiling on OS X 10.5.0

using macbook pro, 10.5.0. Checked out revision 20691.

getting error on building with
./configure macosx64
make -j2

Output from last “make” command:

==> lib/libRLDAP.dylib done
Options to Xrootd-configure: --ccflavour=macos64 --disable-gsi --disable-krb4 --enable-echo --no-arch-subdirs --disable-mon
Guessing architecture/compiler: darwin:i386:9.0.0
darwin | i386 | 9.0.0 | macosx | macos
Invalid architecture. Try ./configure.classic --help
*** Error condition reported by Xrootd-configure (rc = 1): building only the client …
Generating dictionary netx/src/G__Netx.cxx…
utils/src/rootcint_tmp -cint -f netx/src/G__Netx.cxx -c -Ixrootd/src/xrootd/src netx/inc/TXNetFile.h netx/inc/TXNetFileStager.h netx/inc/TXNetSystem.h netx/inc/LinkDef.h
bin/rmkdepend -R -fnetx/src/G__Netx.d -Y -w 1000 –
-m64 -pipe -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -Ixrootd/src/xrootd/src -D__cplusplus -Icint/lib/prec_stl
-Icint/stl – netx/src/G__Netx.cxx
g++ -m64 -pipe -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -Ixrootd/src/xrootd/src -I. -o netx/src/G__Netx.o -c netx/src/G__Netx.cxx
g++ -O2 -m64 -dynamiclib -single_module -undefined dynamic_lookup -install_name /usr/local/root/lib/libNetx.dylib -m64 -o lib/libNetx.dylib netx/src/TXNetFile.o netx/src/TXNetFileStager.o netx/src/TXNetSystem.o netx/src/G__Netx.o -ldl -Lxrootd/src/xrootd/lib -lXrdOuc -lXrdSys -Llib -lXrdClient
ld: library not found for -lXrdOuc
collect2: ld returned 1 exit status
make: *** [lib/libNetx.dylib] Error 1

We expect to import a version of xrootd ported to Mac OS X 64bit later today. I’ll keep you posted.

Cheers, Fons.

Am I the first using the macosx64 compiler option, or just the first to use it in conjunction with 10.5?

What’s the quickest way to get ROOT to run?

I am already running 10.5 macosx64 and I’ve fixed xrootd. We are waiting for one more fix and then we will roll in the new xrootd. I’ll keep you posted.

Cheers, Fons.

The fix is now in the svn trunk.

Cheers, Fons.

Thanks, this worked!