(not able to) run root on windows XP

Hi all,

I tried to run root on windows XP. After one hour
of desperate hacking I gave up.

Does anyone know a (good) webpage which explains
how to proceed (including this EXTREMELY painful installation
of something called CYGWIN)?

I tried to run root within this cygwin stuff (i don’t know how I could
ever manage to get through the installation process of it …) but it
always complained about missing libs (X11). It was impossible for
me to tell the cygwin installer to install this library (and they did not
come with the default installation).

Then I read another post that it is possible to start it from a DOS
prompt, but I could not manage either (same lib problem).

A detailed howto would be great and very helpful!

Thanks a lot!

I am very unfamiliar with windows XP (linux rules :wink: ) but to my knowledge all windows XP installations are very much alike.
Would it not be possible to provide one download with all libs needed to just run root (including what is needed of my new favourite software package cygwin)?

Hi Andi,
the simplest way:

  1. you do not need cygwin installed
  2. get binaries form root.cern.ch/root/Version400.html

“WindowsXP/NT/w2000 with VC++ 7.0 (runs with VC++6), version 4.00/08 (good old tar file) WIN32GDK

  1. check the notes at the bottom of page root.cern.ch/root/Version400.html

That’s all.

Regards. Valeriy


I have “InstallShield Developer” but do not have experience with it.
Could anybody to help me to prepare InstallShield script for ROOT?

Installing root under windows xp is possible. I just did it this week-end.

I installed the cygwin and it devel package alittle bit at a time. I have dial up. You have to install alot of the gcc to get it to build.

I then downloaded the binary for windows for gcc. I untared the root directory into “c:/cygwin/usr/local/bin/” folder.

Then make a text file called root.txt with the follwoing
export ROOTSYS=/usr/local/bin/root
export PATH=$ROOTSYS/bin:$PATH
I then renamed the root.txt to root.sh and put it in
"c:/cygwin/ect/profile.d" directory.

After that when I want to run root I start cygwin then I type: startx and a new terminal starts and then I type “root”

web help a little bit

Hope this helps

I tried Valeriy’s approach already but it did not work (because
of the library issue). But if it is supposed to work like that
I will give it a try again.

Just for info: I do not have anything special installed on
my windows xp: no compiler (I do not want to compile root), no X11 libs or what so ever.

Do I need any of this or is it enough to get the binaries
from root.cern.ch/root/Version400.html (which I did already)
(i.e. are these things included in the download)


Hi Andi,
what is the library issue?
Do you miss some of these?

*  dformd.dll
* MSVCP70.dll
* MSVCR70.dll
* MSVCI70.dll
* MSFRT40.dll

Some old Windows systems may also require:


You do need “no compiler (I do not want to compile root), no X11 libs or what so ever.”

Regards. Valeriy

Hi Valeriy,

of course everything was my fault :frowning:
I downloaded the wrong version (the one for cygwin) and that’s
why I had this libX11 missing lib issue.

with the other version it works fine. I had to download two of these
MSVCP70.dll libs (eventhough I am on XP).

One suggestion I have is:
I am used to scripting on linux but have no idea what to do on windows.
It would be nice if you gave a hint on how to use a
script to automatize the setting of the variables in the MSDOS window.
(I tried with a script in my %HOME% called rootinit.txt but I have no idea how
to source/execute it with windows …)


Hi Andi.
two options:

  • set the vars in start -> settings -> control panel -> system -> advanced tab, environment variables button, and add them. These env vars are available to all programs (which are launched after you changed this setting), i.e. you can even run root directly, without calling it from cmd.exe.
  • put them into a batch file (e.g. rootvars.bat), with “set ROOTSYS=…”. Put it into your PATH, e.g. C:\WINDOWS. Run it before starting root.

InstallShield installation is available from root.bnl.gov

It does include ROOT qith “old” WIN32 interface as well as with Qt layer.
It doesn’t include “win323gdk” yet.

To install this version of root just click the link:


This should be sufficident !!!

If you still have some troubles with the ROOT installtion then this means I have some bug in my InstrallShield script to fix.
Please drop me a message as soon as spossible.