No TBrowser

I downloaded the 5.25 source and compiled it without a problem. I added set $ROOTSYS and added it to the path. When I run command root, root loads normally w/o error message. However, when I enter TBrowser b, nothing seems to happen. Also, TCanvas Draw doesn’t work. Here are some command. Notice that the commands that require a GUI window seem to work.

root [9] gStyle->SetPalette(1) root [10] gRoot->SetBatch(0) Error: Symbol gRoot is not defined in current scope (tmpfile):1: Error: Failed to evaluate gRoot->SetBatch(0) *** Interpreter error recovered *** root [11] gROOT->SetBatch(0) root [12] c2->Draw() root [13] c2->GetName() (const char* 0xad5128)"myCanvas" root [14] c2->Draw() root [15] TBrowser b root [16]

I do not understand what you are trying to do. By calling gROOT->SetBatch(0) you instruct the system to not display anything on your screen.


Note the first command after start up is

Nothing happens, no window and no error message. The rest is just monkeying around trying to get something to happen (but doesn’t SetBatch(1) tell ROOT not to display??).

The trouble is that ROOT on this system will not display any type of window, not a TBrowser, not a TCanvas, not a tree->Draw(“variable1”). Nothing and no error. I have used root on many different systems and different environments. This is some type of installation or build problem. I should note that I am attempting to build and run on system on which I do not have root user privileges so I use

./configure --prefix=/home/ME/root make make install.

Did you have errors when installing ROOT? Could you post the config.log and config.status files?
Did you modify the system.rootrc file?
Do you have a rootlogon.C file where you set the batch mode?


I’ve attached the config.log
the config status is

--prefix=[MY HOME DIR]/root

I didn’t notice any errors and I have not modified system.rootrc.

I did not do anything with SetBatch mode except which I was just typing stuff on the command prompt.
config.log.txt (415 KB)


how exactly do you start root?

Cheers, Axel.

I’ve tried entering root, root.exe, and root -l. They all seem to do the right thing but then nothing happens when I enter TBrowser b at the prompt.


what happens if you run
root [0] gApplication->InitializeGraphics()
root [1] new TBrowser

Cheers, Axel.

[code]$ root -l
root [0] gApplication->InitializeGraphics()
root [1] new TBrowser
(class TBrowser*)0x9cf860
root [2] TBrowser *b = new TBrowser()
root [3] b->Draw()
Warning in TCanvas::ResizePad: c1 width changed from 0 to 10

Warning in TCanvas::ResizePad: c1 height changed from 0 to 10

TCanvas::MakeDefCanvas: created default TCanvas with name c1
root [4]

Still no TBrowser window. I should also note that .! xterm does open up an xterminal.


no idea. You probably have a broken installation of ROOT. Did you build (even partially) and then re-configure with --prefix? That won’t work. Either way, please read the “Building ROOT” web page … oot-source carefully: if followed you will get a working build of ROOT.

If none of that helps you’ll have to give one of us access to your machine to debug this; please contact us (e.g. me, by email for the login credentials.

Cheers, Axel.

Hi Axel,

Unfortunately, we can’t give you access to the system. I’m going to have the system administrator rebuild ROOT from scratch using root account. If that doesn’t work, I might be back here once again begging for help.


maybe the problem is graphics displaying? When you start root as

, not

do you see an image?

Do you work right on this computer or you login to an another via ssh or something like that? How do you transfer graphics (xming, exceed?) Try to understand, can you see graphics at all by executing the simplest command that has to show watches:

Hi Axel,

At the end of my [make install] output I see Installing macros in {MYHOME}/root/share/root/macros Installing man(1) pages in {MYHOME}/root/share/man/man1 Installing config files in /etc/root mkdir: cannot create directory `/etc/root': Permission denied cp: `/etc/root': specified destination directory does not exist Try `cp --help' for more information. Installing Autoconf macro in {MYHOME}/root/share/aclocal Installing Emacs Lisp library in {MYHOME}/root/share/emacs/site-lisp Installing GDML conversion scripts in {MYHOME}/root/lib/root

Since I used a [–prefix=], I don’t expect the install to try to write to /etc/root. Do you know why it would do that? Could this be the problem?

Yus - thanks for the suggestion. I do have graphics working. I tried [.! xterm] rather than xclock and it did open.


./configure --prefix=XXXX --etcdir=YYYYY and then rerunning make install fixed the problem.