No TBrowser display of ROOT in Ubuntu intalled on Windows

I have installed Root on Ubuntu App on WIndows 10. The installation was successful but when I run
[ ] new TBrowser
it does not open any new window. Please suggest how I can solve this problem.

_ROOT Version: 6.23/01
_Platform: Ubuntu App on WIndows
Compiler: Not Provided

Do you have a X11 server, like XMing? If not, see Running Graphical Applications in the WSL Page of Ubuntu Wiki

Thanks @bellenot
I did install Xming on windows. But it seems I am not able to link it somehow. I simply downloaded Xming and installed the app and it changed nothing. Do I need to run some command on ubuntu terminal after that?

I also added these lines in .bashrc as suggested on the WSL page of Ubuntu Wiki :

export DISPLAY=:0 # in WSL 1
export DISPLAY=$(awk ‘/nameserver / {print $2; exit}’ /etc/resolv.conf 2>/dev/null):0 # in WSL 2

Still no difference.

I am also a newbie but maybe I can help. When you open xlaunch, maybe you can try choose the “no access control” optional.

What does ROOT say when you do [] new TBrowser? does it give any error message?
A sanity check: are you actually running Xming? Its icon should be present in the Windows task bar (on the right side, near the clock).
Also, try adding only this line to .bashrc (instead of the 3 you have):

export DISPLAY=localhost:0

Thanks. It’s working now.
I wasn’t running running Xming. There’s Xming and XLaunch and I was trying to run Xming without completing the information in XLaunch. Thank you @Zhenhao for the suggestion, it was helpful.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.