No module named ROOT while executing script in windows

I am trying to run a .py script (that refers to diffierent root libraries) on Windows10, using the powershell. I get an error message:
ImportError: No module named ROOT.
Tried to follow the threads dealing with missing root and pyroot modules, but was not able to resolve the problem. I also tried in Pengwin Enterprice to execute the line:
sudo yum install -y root python3-root
that would give me back: No package root available.
No package python3-root available.
How do I resolve this?

Please read tips for efficient and successful posting and posting code

_ROOT Version:_6.22.02
Platform: Windows10
Compiler: PowerShell

How did you install ROOT? Did you call root\bin\thisroot.bat before starting Python?

By the installation file for windows. No, I didn’t call the thisroot.bat. Actually, I am calling teh .py script by a .sh file

So please call root\bin\thisroot.bat to properly set-up the environment variables, or do it manually by adding the ROOTSYS environment variable (pointing to your root install location), add %ROOTSYS%\bin to your PATH, and add %ROOTSYS%\bin to your PYTHONPATH. BTW, I’m not sure it will work from PowerShell. And note also that PyROOT might not be fully working on Windows

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.