No module named ROOT (GNU/Linux)

Hello everyone,

I run a debian jessie installation.
PyROOT was usually working after i did

apt-get install root-system apt-get install libroot-bindings-python-dev

but now it does not.
I removed and reinstalled the above packages + all dependencies.
However i still get:

[code]>>> from ROOT import *
Traceback (most recent call last):
File “”, line 1, in
ImportError: No module named ROOT


any help is appreciated.


not a debian expert here, but can you check where and are located underneath the ROOT installation? Presumably $ROOTSYS is still set? Once found, are those modules locatable through PYTHONPATH?


b@oeb:~$ locate /usr/lib/x86_64-linux-gnu/root5.34/ /usr/share/python-support/root/

b@oeb:~$ locate /usr/lib/pyshared/python2.7/ /usr/lib/python2.7/dist-packages/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/ /usr/lib/x86_64-linux-gnu/root5.34/ /usr/lib/x86_64-linux-gnu/root5.34/ /usr/lib/x86_64-linux-gnu/root5.34/

$ROOTSYS and $PYTHONPATH are both not set

[code]b@oeb:~$ echo $ROOTSYS

b@oeb:~$ echo $PYTHONPATH


I now set $PYTHONPATH to /usr/share/python-support/root
and this helped: I can now ‘import ROOT’.

However I wonder if those variables should actually contain more (and of course why this problem started. It worked well the week before.)

anyway, no problems so far.

Thank you for the tips Wim!

I faced same problem. I just tried to install PyROOT and I am a newcomer to it. I edit my ~/.bashrc file and add $PYTHONPATH to /home/rik/root/bindings/pyroot/ (location of and got same error. Can anyone help me how to overcome this?
Also, please guide me how to enabled PyROOT properly with ROOT?

I just follow these procedures but got error.

How did you install ROOT? From the repositories of your linux distribution or did you compiled yourself from the sources?

Thanks for your reply!
I download it from git repository and then compile it with python 2.7.14 and root 6.10.08…
configure it by
./configure linux --enable-python --with-python-incdir=/usr/include/python2.7/ --with-python-libdir=/usr/lib/ and then make & make install…finally edit ~/.bashrc file…

But still got the message when I write

from ROOT import *
Traceback (most recent call last):
File “”, line 1, in
ImportError: No module named ROOT

I don’t understand I am doing right or wrong for pyroot…can you please guide me as I am new to Pyroot…

Thanks in advance.

add $PYTHONPATH to /home/rik/root/bindings/pyroot/

not sure how to parse the above sentence … I presume first of all in the above that you mean the reverse, but also you want the path to the file in the PYTHONPATH envar, not the file itself. Further, the above looks like it points to the sources, not the installation. You want the latter.

In sum, $ROOTSYS/lib is what should be in PYTHONPATH.