No icons in GUIbuilder (ROOT 5.11/02) [SOLVED]

Dear Users & Developers,
I have installed the latest stable version of ROOT (5.11/02) but the toolbar of GUIbuilder has no icons, instead I see question marks :question: in the place. Did I miss something?

Thanks, Luís A. Perles

Hi Luís,

It seems that the *.png files are missing in your $ROOTSYS/icons directory. The latest version of ROOT GUI builder uses them and if they are missing, the default question mark icon is used. From where did you install root?

Thank you, Ilka

Hello Ilka,
I do not set the ROOTSYS, I use a “default system wide” installation, which means that ROOT binaries are in /usr/bin, the includes in /usr/include/root and the libs in /usr/lib/root. I also have /usr/share/root where I find these directories: cint fonts icons macros.
Is there any other way to set up the icons path?
I also tired to set ROOTSYS pointing to /usr/share/root with no succes at all.

Thanks, Luís

Hi Luís,

Before you can run ROOT you need to set the environment variable $ROOTSYS and change your path to include $ROOTSYS/bin and library path variables to include $ROOTSYS/lib. ROOTSYS is an environment variable pointing to the directory where you unpacked the ROOT distribution.

Cheers, Ilka

Hello Ilka

Since I’ve moved to Gentoo Linux 2 years ago I’ve adopted that installation way with no troubles at all. Such installation is suggested by the Gentoo package system called portage.
I’ve found that such installation way is possible and should work properly from this link
Another test I’ve done is to try to execute a macro which is not in the current directory (ROOT will try to find it in the default macros directory), I’ve got this message:

root [0] .x teste.C Error in <TRint>: macro teste.C not found in path .:/usr/share/root/macros
So my current ROOT installation can find the macros directory properly, and I suppose that the GUIBuilder Interface should does the same for the icons directory, isn’t it?
I think this is a bug because in my old ROOT 5.08/00 installation everything worked fine.

Cheers, Luís

Hi Luís,

After details you provided I think you are right - the GUI builder should find somehow its *.png icons.

Cheers, Ilka

do you have
Gui.IconPath: $(HOME)/icons:$(ROOTSYS)/icons:.
set in your ROOT resource file (either system.rootrc or .rootrc )?

Hi Valeriy

Yes, I do have that line in my system.root, which is:
Gui.IconPath: $(HOME)/icons:/usr/share/root/icons:.

And is pointing to correct directory (/usr/share/root/icons).
Cheers, Luís

Can you browse PNG files with ROOT browser?

  • just run TBrowser and click on some PNG image
  • new TCanvas should be created with PNG image inside.

Hi Valeriy an Ilka,

Ohhh, sorry people!
I’ve found out the problem! The ROOT are able to open PNG file properly.

I forgot to check if there were some PNG files in the icons directory. I saw a lot of pictures and I thought that PNG were among of them, there were only XPM pictures (I realy need to sleep!).

The problem is the ROOT installation script did not copied the PNG files to icons directory, just XPM pictures (BUG?!). After manualy copy all PNG files I could see the icons in the toolbar.

Again, sorry everyboby and thank you all.
Cheers, Luís

Hi Luís,

No problem. It is good that you found the reason - the missing *.png files in the icons directory.

Cheers, Ilka