No Graphics Display


Just installed root-v5-26-00d onto Intel machine running Red Hat 4.1.2-48.
After installation typed “root” and the splash screen appeared (as expected).

Then typed:
"root[0] TBrowser b"
and nothing appeared. Additionally, I check creating a TCanvas and running some
of the macros in the Tutorials folder. In all cases the splash screen will appear but
no graphics. Also, there are no errors (such as an X11 error) that appear when trying
to draw these objects.

The following was used in installation:

./configure $confarch

with $prefix being home directory
$level being new
$confarch being linux

Appreicate the help,

Hi Zach,

Weird. Can you make sure that ROOT is not in batch mode? It should gives something like this:

root [1] gROOT->IsBatch() (const Bool_t)0 root [2]
If it is in batch (returning (const Bool_t)1), check that you don’t have gROOT->SetBatch(kTRUE); in your rootlogon.C, or if you don’t have any message telling that you’re switching in bach mode, like for example:
Error in : can’t open display “:0.0”, switching to batch mode…

Cheers, Bertrand.


I had the same thought as well and had checked the batch mode.
I just checked again and get:

root [0] gROOT->IsBatch()
(const Bool_t)0
root [1] 

So, it is not in batch mode. I agree that this a weird occurence. I have installed
root before on Ubunut and Scientific Linux distros with no problem.
It is interesting that the graphics won’t display yet the splash screen does.


And you have no error message at all when trying to open a Canvas?
Could you try without using prefix?

Cheers, Bertrand.

Correct, there are no error messages when opening a TCanvas.

I can’t remove the prefix, because I am a user on a cluster and do
not have permission to write to /usr…etc…


Well, I think you don’t need to use prefix:

configure [your list of options] make should be sufficient (no need of make install). Then you can use the root/bin/thisroot.[c]sh macro to set the correct environment variables…
Sorry but I have no idea what could go wrong, and I can’t really try anything now (I’m away from CERN until next week), but I’ll try to investigate as soon as I’m back. In the meanwhile, you could try to google for this kind of problem…
EDIT: You could also try to search on this forum…

Cheers, Bertrand.

Thanks the ideas.
We have tried to install without the prefix and then use the
thisroot.csh to set the enviorment. However, we still are not
getting any graphics.


Additional/New information that may help us in solving the issue.

I re-installed root. As suggested I did not use the prefix option. The configure was
as follows:
./configure $confarch

This is root-5-v26-00b.
After this I tried to draw a blank histogram and got the following

root [0] TH1F *hh = new TH1F("hh","hh",100,0,100);
root [1] hh->Draw()
Warning in <TCanvas::ResizePad>: c1 width changed from 0 to 10

Warning in <TCanvas::ResizePad>: c1 height changed from 0 to 10

<TCanvas::MakeDefCanvas>: created default TCanvas with name c1

 *** Break *** segmentation violation

There was a crash (#7 0x007185dd in SigHandler(ESignals) () from /nfs_home/zkohley/root-5-26-00b/lib/
This is the entire stack trace of all threads:
#0  0x00ea2416 in __kernel_vsyscall ()
#1  0x00d50463 in __waitpid_nocancel () from /lib/
#2  0x00cec753 in do_system () from /lib/
#3  0x0046275d in system () from /lib/
#4  0x007114cd in TUnixSystem::Exec(char const*) () from /nfs_home/zkohley/root-5-26-00b/lib/
#5  0x007172e0 in TUnixSystem::StackTrace() () from /nfs_home/zkohley/root-5-26-00b/lib/
#6  0x007184d5 in TUnixSystem::DispatchSignals(ESignals) () from /nfs_home/zkohley/root-5-26-00b/lib/
#7  0x007185dd in SigHandler(ESignals) () from /nfs_home/zkohley/root-5-26-00b/lib/
#8  0x0070e292 in sighandler(int) () from /nfs_home/zkohley/root-5-26-00b/lib/
#9  <signal handler called>
#10 0x006d7bc0 in TClass::New(TClass::ENewType) const () from /nfs_home/zkohley/root-5-26-00b/lib/
#11 0x021c0b56 in TVirtualHistPainter::HistPainter(TH1*) () from /nfs_home/zkohley/root-5-26-00b/lib/
#12 0x021371fb in TH1::GetPainter(char const*) () from /nfs_home/zkohley/root-5-26-00b/lib/
#13 0x0213724c in TH1::Paint(char const*) () from /nfs_home/zkohley/root-5-26-00b/lib/
#14 0x035a037f in TPad::PaintModified() () from /nfs_home/zkohley/root-5-26-00b/lib/
#15 0x03586ccb in TCanvas::Update() () from /nfs_home/zkohley/root-5-26-00b/lib/
#16 0x006fc3a7 in TCint::UpdateAllCanvases() () from /nfs_home/zkohley/root-5-26-00b/lib/
#17 0x00701205 in TCint::ProcessLine(char const*, TInterpreter::EErrorCode*) () from /nfs_home/zkohley/root-5-26-00b/lib/
#18 0x006fd611 in TCint::ProcessLineSynch(char const*, TInterpreter::EErrorCode*) () from /nfs_home/zkohley/root-5-26-00b/lib/
#19 0x006f9714 in TCint::EndOfLineAction() () from /nfs_home/zkohley/root-5-26-00b/lib/
#20 0x002f8c1b in TRint::HandleTermInput() () from /nfs_home/zkohley/root-5-26-00b/lib/
#21 0x002f72e5 in TTermInputHandler::Notify() () from /nfs_home/zkohley/root-5-26-00b/lib/
#22 0x002f9634 in TTermInputHandler::ReadNotify() () from /nfs_home/zkohley/root-5-26-00b/lib/
#23 0x00714f77 in TUnixSystem::CheckDescriptors() () from /nfs_home/zkohley/root-5-26-00b/lib/
#24 0x007152c5 in TUnixSystem::DispatchOneEvent(bool) () from /nfs_home/zkohley/root-5-26-00b/lib/
#25 0x00695151 in TSystem::InnerLoop() () from /nfs_home/zkohley/root-5-26-00b/lib/
#26 0x006975f9 in TSystem::Run() () from /nfs_home/zkohley/root-5-26-00b/lib/
#27 0x0063e7c7 in TApplication::Run(bool) () from /nfs_home/zkohley/root-5-26-00b/lib/
#28 0x002f8f48 in TRint::Run(bool) () from /nfs_home/zkohley/root-5-26-00b/lib/
#29 0x08048d9f in main ()

Hopefully this can help you in finding the problem.

It looks like a configuration/installation problem. I use SLC4 (which is based on Red Hat 4) every day without any problem. Are you sure you properly removed any previous version? Are you sure you only typed “./configure [your list of options]” (without using prefix) and then “make” (and not make install)?
Anyway, I’ll try to reproduce the problem on a virtual machine (that I have to set-up) and I’ll let you know.
Cheers, Bertrand.


I have figured out the problem. It actually is do to the fact that I had a old .rootrc file
in my home directory. The dynamic and plugin paths were not correct anymore. I
believe that is what was causing the errors.
After removing the .rootrc file, everything appears to be working properly.

Sorry for taking up your time on this.