No Fonds in Batch mode

Hey people,

I’ld like to run a few macros in batch mode. These should
dump some histograms into different ps files.

Unfortunaltely though working fine in interactive mode
in batch mode root does not find any fonds complainig
like this:

Error in TTF::SetTextFont: font file arialbd.ttf not found in path
Error in TTF::SetTextSize: current font index out of bounds

at any occasion. Of course I need histograms with axis lables and legends.
Can anyone tell me what my problem is and how it can be cured?

Greetings from HH,

Could you send the shortest possible script reproducing your problem?

There should be no problem to produce ps files in batch mode.
Note also that in the new release 4.04 it is possible
to produce gif, jpg, bpm, png files in batch mode.


Hi Rene,
thanx for your reply and sorry for being late,
for some reason I forgot to let me notify on
your reply…

the shortes script would be:

void test()
TH1F* hist = new TH1F(“hist”, “MyTitle”, 10, 0., 10.);

//fill hist
for(Int_t i=0; i<10; ++i){
hist->Fill(i, i);

//draw hist to file
TCanvas *canv = new TCanvas(“canv”, “MyCanvas”, 800, 600);

TPostScript psFile(“”, 112);
//type 111 portrait
// 112 landscape
// 113 eps
//psFile.Range(28,35); //for 2X2 histos per page



i’m using root 3.10/03.

if i run it interactively starting root and typing

.x test.C
everything is fine.

if i run it in with

root -b -q test.C

it results in a flush of errors of this kind:

Error in TTF::SetTextSize: current font index out of bounds
Error in TTF::SetTextFont: font file times.ttf not found in path

and the resulting ps file contains no single letter.

hope you can help me with this.
Cheers Roger