No clue how to debug ACLiC_dict errors

I inherited some C/C++ code and I’ve been making modifications to it. However, I’ve come to the conclusion that using some of ROOT’s histogramming and graphing capabilities will become handy.

I’m doing this in Windows 7 64-bits, with VC++ 2010 (or version 10.0) and ROOT 5.34/20

Before the “ROOT” additions, the program compiles fine with VC++ 2010 using the simpler command-line compiler “cl.exe”. Trying to compile within ROOT using ACLiC I get a bunch of error messages that have no correlation to my original source file, for example:

Source filename: xy_def_coord.cxx

First error message:
xy_def_coord_cxx_ACLiC_dict.cxx(175) : error C4430 : missing type specifier - int assumed. Note: C++ does not support default-int

I don’t understand how to debug these errors when they are actually found in some temporary file that doesn’t stay after trying to compile! (I tried setting gDebug = 3 and gDebug = 7 but this didn’t seem to do anything).

This is likely a newb question. I apologize, but I couldn’t find much info in the documentation. I’ve used ROOT before in a Linux environment using g++ and stuff worked correctly.


The xy_def_coord_cxx_ACLiC_dict.cxx file is the dictionary file automatically generated by ACLiC, and it is generated from your code. Now, if you need to keep the intermediate files around, for example when debugging the script, use gDebug=7

Cheers, Bertrand.