New software in ubuntu LTS 20.04.3

I am installing a new software in ubuntu LTS 20.04.3. Its called NiasMARS. It is a .sh file. But i cant seem to get away with this error of compling root libraries. I dont have much experience with Linux and commands. Can someone please help

ROOT Version: 6-24-06
Platform: Ubuntu LTS 20.04.3

The error message explicitly says that you should inspect the “/tmp/.niasMARS.out” and “/tmp/.niasMARS.err” files.

BTW. In general, most probably, you will need to contact the authors of the “NiasMARS” software for help.

That error message is just printed out of the code in that .sh file. In actual, those files do not exist. I dont understand what to do. I have tried everything that I could find on the youtube. On the top of that, every folder involved in the install is requiring permission to be accessed, and some are being denied and not allowing new directories to work. I tried chmod 777 ./ command but apparently that’s just a temporary command until your next reboot. Can you at least help me removing all the permissions? This is a personal PC so I am not concerned about data leak. Thanks for your time.

Hi @psharma1137 ,
and welcome to the ROOT forum! The error seems to be strictly related to NiasMARS so you might have better luck in channels dedicated to NiasMARS support, I am not sure whether any experts hang around this forum.

I am not sure whether it might help, but chmod -R a+rw some_directory makes all files under some_directory readable and writable by the world. That is not temporary, it’s a permanent change.

Also note that /tmp/.niasMARS.err, because of the . at the beginning of the filename, is a hidden file on linux so it might not come up in file listings unless you use some special options.


Try (note: “/tmp” may be cleaned on every reboot): ls -al /tmp

BTW. You use “sudo”, so you should not get any permission problems.