New ROOT v6.20.04 installation doesn't work

Hi, I have newly installed ROOT on my Mac OS X 10.15.4 Catalina and when I try to execute any of my macros, that used to work there is this error message. Thank you for your help!

 *** Break *** segmentation violation
[/usr/lib/system/libsystem_platform.dylib] _sigtramp (no debug info)
[<unknown binary>] (no debug info)
[/usr/lib/system/libsystem_c.dylib] fscanf (no debug info)
[<unknown binary>] (no debug info)
[<unknown binary>] (no debug info)
[/Applications/root_v6.20.04/lib/] cling::IncrementalExecutor::executeWrapper(llvm::StringRef, cling::Value*) const (no debug info)
[/Applications/root_v6.20.04/lib/] cling::Interpreter::RunFunction(clang::FunctionDecl const*, cling::Value*) (no debug info)
[/Applications/root_v6.20.04/lib/] cling::Interpreter::EvaluateInternal(std::__1::basic_string<char, std::__1::char_traits<char>, std::__1::allocator<char> > const&, cling::CompilationOptions, cling::Value*, cling::Transaction**, unsigned long) (no debug info)
[/Applications/root_v6.20.04/lib/] cling::MetaSema::actOnxCommand(llvm::StringRef, llvm::StringRef, cling::Value*) (no debug info)
[/Applications/root_v6.20.04/lib/] cling::MetaParser::isXCommand(cling::MetaSema::ActionResult&, cling::Value*) (no debug info)
[/Applications/root_v6.20.04/lib/] cling::MetaParser::isCommand(cling::MetaSema::ActionResult&, cling::Value*) (no debug info)
[/Applications/root_v6.20.04/lib/] cling::MetaProcessor::process(llvm::StringRef, cling::Interpreter::CompilationResult&, cling::Value*, bool) (no debug info)
[/Applications/root_v6.20.04/lib/] HandleInterpreterException(cling::MetaProcessor*, char const*, cling::Interpreter::CompilationResult&, cling::Value*) (no debug info)
[/Applications/root_v6.20.04/lib/] TCling::ProcessLine(char const*, TInterpreter::EErrorCode*) (no debug info)
[/Applications/root_v6.20.04/lib/] TCling::ProcessLineSynch(char const*, TInterpreter::EErrorCode*) (no debug info)
[/Applications/root_v6.20.04/lib/] TApplication::ExecuteFile(char const*, int*, bool) (no debug info)
[/Applications/root_v6.20.04/lib/] TRint::ProcessLineNr(char const*, char const*, int*) (no debug info)
[/Applications/root_v6.20.04/lib/] TRint::HandleTermInput() (no debug info)
[/Applications/root_v6.20.04/lib/] TUnixSystem::CheckDescriptors() (no debug info)
[/Applications/root_v6.20.04/lib/] TMacOSXSystem::DispatchOneEvent(bool) (no debug info)
[/Applications/root_v6.20.04/lib/] TSystem::InnerLoop() (no debug info)
[/Applications/root_v6.20.04/lib/] TSystem::Run() (no debug info)
[/Applications/root_v6.20.04/lib/] TApplication::Run(bool) (no debug info)
[/Applications/root_v6.20.04/lib/] TRint::Run(bool) (no debug info)
[/Applications/root_v6.20.04/bin/root.exe] main (no debug info)
[/usr/lib/system/libdyld.dylib] start (no debug info)


This looks like a problem in a macro that calls fscanf. Let’s cross check that first:

  • Am I correct that this crash happens while running a macro file of yours (as you hint in the bug report)?
  • Does this macro contain a call to fscanf?

It might be that your macro is in your home / Downloads / … directory, and MacOS prevents ROOT from accessing files there. Right after such a crash you can check in Settings, Security & Privacy, the tab titled Privacy, select Files and Folders from the list - there might be a message saying “ROOT tried to access XYZ, click to allow” or similar. See for what this should look like.

Can you confirm that this helps?

Cheers, Axel.

1 Like

Thank you for your response. I have tried what you have suggested, but there is no message to allow in Files and Folders

Please answer the other questions of mine so I can continue to help.
Cheers, Axel.

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.