New install ubuntu13.04 Error in <TUnixSystem::DynamicPath


I just installed root 5.34/00 on my Ubuntu 13.04, using the Ubuntu Software Center. I thought everything was going painlessly until I tried to save a histogram:

Error in TUnixSystem::DynamicPathName: Postscript[.so | .dll | .dylib | .sl | .dl | .a] does not exist in /lib::.::/usr/lib/x86_64-linux-gnu/root5.34:/usr/lib/x86_64-linux-gnu/root5.34/cint/stl

What can I do to rectify this?

Some information that might help:
~> echo $ROOTSYS; echo $PATH; echo $LD_LIBRARY_PATH


1 Like

I’m not sure how it’s looks in ubuntu repository but in debian repo there are many option of installation external packages for root e.g. there is libroot-graf2d-postscript5.32.
So I suppose that ubu repo center don’t install ROOT with all feautures, and you should try to install this package speratelly by synaptic or aptitude.

1 Like

Thank you, it solved my problem with the same distribution!

This did not work for me when I tried to write my plot to a .gif file.

Is there something else I have to install?

Try apt-get install root-system. That will install ROOT with all components. However, I really recommend that you move to ROOT 6 instead, since it has much better support for C++.