Need help to compile root latest version

i am at the beginning of using root. so i think, my problem is not difficult for you. i have been trying to install root_v5.04.00 for two days. i read most of the documentions (about installation, configure and readme…) and tried everything. i want to tell step by step…

  1. downloaded the root_v5.04.00.source.tar.gz to the computer
  2. gunzip root_v5.04.00.source.tar.gz
  3. tar xvf root_v5.04.00.source.tar
  4. cd root
  5. ./configure linux (i use scientific linux cern 3.0.3)
  6. make
    but the problem that the computer compile it for hours and never stops. it copies the same files again and again. how must i do? if somebody interests and replies, i ll be happy!


you provide very little info, so all I can do is guess what’s happening. It sounds like a problem with the system time of your machine. make thinks it needs to copy A to B, because A is newer than B. But after copying A is still newer than B, so it keeps on trying. This happens if your system time is before the date of file A. Fix that, and you should be fine.

If it’s not a time issue please send the build output, and an ls -l $ROOTSYS/base/inc/ $ROOTSYS/include/

Cheers, Axel.

thanks for your interests very much. the problem was solved. i will be able to start studying root anymore.