Module libc not found (take 2)

This issue has been bothering me since quite a while, and apparently I’m not absolutely alone. (Module libc not found)

As I remember, it started after one of the standard Ubuntu GCC 9 updates >1 year ago. After the APT update most of my ROOT builds became non-functional. After I re-built a few of them, they started working, but I would continue getting this error/warning message from them.

[bash][Legolas]:~ > source ~/software/root/6.26.06/x86_64-ubuntu2004-gcc9-opt/setup.sh 
Configured TBB from: /home/krasznaa/software/oneTBB/2021.5.0/x86_64-ubuntu2004-gcc9-opt
Configured XRootD from: /home/krasznaa/software/xrootd/5.5.0/x86_64-ubuntu2004-gcc9-opt
Configured ROOT from: /home/krasznaa/software/root/6.26.06/x86_64-ubuntu2004-gcc9-opt
[bash][Legolas]:~ > root
Module libc not found.
   ------------------------------------------------------------------
  | Welcome to ROOT 6.26/06                        https://root.cern |
  | (c) 1995-2021, The ROOT Team; conception: R. Brun, F. Rademakers |
  | Built for linuxx8664gcc on Jul 28 2022, 18:08:51                 |
  | From tags/v6-26-06@v6-26-06                                      |
  | With c++ (Ubuntu 9.4.0-1ubuntu1~20.04.1) 9.4.0                   |
  | Try '.help', '.demo', '.license', '.credits', '.quit'/'.q'       |
   ------------------------------------------------------------------

root [0]

And the PCM file in question is indeed not there, the build was not able to create it.

[bash][Legolas]:~ > ls -l software/root/6.26.06/x86_64-ubuntu2004-gcc9-opt/lib/libc.pcm
ls: cannot access 'software/root/6.26.06/x86_64-ubuntu2004-gcc9-opt/lib/libc.pcm': No such file or directory
[bash][Legolas]:~ >

While on another Ubuntu 20.04 machine the file was created during the build, and I get no similar messages.

[bash][atspot01]:~ > ls -l /atlas/software/root/6.26.06/x86_64-ubuntu2004-gcc9-opt/lib/libc.pcm 
-rw-r--r-- 1 krasznaa krasznaa 2000344 Sep  1 10:50 /atlas/software/root/6.26.06/x86_64-ubuntu2004-gcc9-opt/lib/libc.pcm
[bash][atspot01]:~ >

Finally, when I tried to copy the build from the machine that does not show these issues to the machine that does, ROOT was completely unusable on the “problematic” PC. (It died a horrible death as soon as it tried to load libc.pcm.)

I know that the earlier thread was closed with nobody knowing what’s going on, but did people possibly get an idea since? I’m 95% sure that the problematic PC is missing some package that the other one has. But it’s not one of the ones listed on Dependencies - ROOT. :confused:

This is not preventing me from anything in the end, but I would love to find out what’s causing it.

Cheers,
Attila

ROOT Version: Anything above 6.18 or so…
Platform: x86_64-ubuntu2004-gcc9-opt
Compiler: GCC 9.4


Hello,

@Axel might have an idea of what could be going on?

Did you build ROOT yourself? If so, try with rm lib/*.pcm; make -j12 - that should trigger the rebuild of the missing module.

Hi Axel,

I did, on both machines. On the problematic one libc.pcm is just unable to build for some reason. And the message in question (“Module libc not found”) is printed a lot during the build. (I assume every time that the dictionary generator is invoked.)

So the question is what am I missing from that machine that makes libc.pcm unable to build? :confused:

As I wrote, when I copy a build that includes libc.pcm to the “problematic machine”, that ROOT build is just completely unusable. For some reason even though libc.pcm exists in that case, ROOT is still unable to load/use it.

This is not a high priority as I wrote before. So if you don’t have any ideas right away, then don’t struggle with it…

Cheers,
Attila

Hi Attila,

“Module libc not found” is a consequence of the build error; there should be a build error printed before. Do you have a full log from a build from scratch (or after rm lib/*.pcm)?

Cheers, Axel

Hi Axel,

If only it were so simple… :frowning_face: As you can imagine, I tried to understand it on my own as well.

Here is the full configuration and build log of 6.26/06 on that problematic machine:

Unfortunately I don’t find any smoking guns in them for the reason why libc.pcm is not built. It is just silently not… :confused:

Cheers,
Attila

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.