Minuit2 configuration missing


I have a problem about configuration options.
I need a minuit2 option. so when i was entered the ‘./configure’ commend, i was put the option commend ‘–enable-minuit2’ .
and My configuration result message was

Enabled support for asimage, astiff, builtin_afterimage, builtin_lzma, cintex, explicitlink, fftw3, fitsio, gviz, genvector, krb5, ldap, mathmore, memstat, minuit2, mysql, opengl, python, reflex, shadowpw, shared, ssl, tmva, vdt, x11, xft, xml.

But, After the build ROOT ( I used cmake <My/DIR> following make -j4 ), ROOT didn’t have minuit2 in root options.
(at this time, i use this commend ‘root-config --features’ ).

So, i had a checking few thing. root-config --prefix and version has no problem. Everything was successfully done without minuit2.

and this is my ‘root-config --features’ results.

asimage astiff bonjour builtin_afterimage builtin_ftgl builtin_glew cintex exceptions explicitlink fftw3 fitsio fortran gviz genvector krb5 ldap mathmore memstat mysql odbc opengl python reflex shadowpw shared sqlite ssl thread tmva vdt xft xml x11

If you have any comments or idea, please let me know.

Cheers, Ze.


To configure ROOT with minuit2 you should configure using CMake doing

cmake  .  -Dminuit2=On


1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.