Minuit 2 problems


I’m trying to run a script that uses Minuit2 and get the error:

Limitation: Reference member not supported. Please use pointer Minuit2/ABObj.h:98:

I read that this probably means that I have to build Minuit2 as it’s not built on default.
But I am using root v5 28.00 (and OS X 10.8.3) and checked by
"root-config --has-minuit2"
(it says “yes”) if the libraries are built…they seem to be built.

What else could be the problem?

Any help appreciated!

I think you will get “Minuit” when you try:
std::cout << TVirtualFitter::GetDefaultFitter() << std::endl;
So, you need to:

See also:


I tried that and get the same error. I’ve also looked at every tutorial I could find in the web but still don’t get it working :frowning:

Try to run your script through ACLiC using something like:
root [0] gSystem->Load(“libMinuit2”); // just a precaution
root [1] .x SomeScript.cxx++

Still the same error :confused:

  1. try the newest ROOT v5-34-07 or the v5-34-00-patches branch
  2. if it doesn’t help, post your source code here so that we can try it