MakeNumpyDataFrame function name

I have just had a look to the slides from the ROOT workshop.
Since it is experimental, do you think you will change the name of “MakeNumpyDataFrame”? I think it is very confusing, just reading the name of the function I understand that I am making a numpy data frame, but it is the opposite. It should be symmetric with “AsNumpy”.

Why not FromNumpy? and ToNumpy? (which are more or less the ones used by pandas, e.g. read_json, to_json, …)

In addition also Awkward Array is using a naming that make very sense: from_rdataframe, to_rdataframe.


You have a fair point, but in the case of MakeNumpyDataFrame the convention that is followed for that factory function is the same as for other RDataFrame sources, for example MakeCsvDataFrame or MakeArrowDataFrame.

You can change all of them… FromNumpy, FromCsv, From.... From these names I understand I am creating a csv file for example.

Hi @wiso ,

thank you for the feedback, I agree with the suggestion, we’ll see what we can do :slight_smile:


This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.

I opened [DF] Rename RDF factory functions by eguiraud · Pull Request #11125 · root-project/root · GitHub , discussion continues there.