Home | News | Documentation | Download

Make halts at 71%

Hello, I’m trying to install Cern ROOT, following the installation guide. I cloned files from git repo, mkdir’ed buildroot folder inside cloned directory, called cmake …, later make -j8 as readme stated, making process has started but halted at 71% with the following message:

[ 71%] Building CXX object interpreter/llvm/src/tools/clang/lib/AST/CMakeFiles/obj.clangAST.dir/VTableBuilder.cpp.o
[ 71%] Building CXX object interpreter/llvm/src/tools/clang/lib/AST/CMakeFiles/obj.clangAST.dir/VTTBuilder.cpp.o
[ 71%] Built target obj.clangAST
make: *** [Makefile:152: all] Error 2

I tried to search this error code but couldn’t find similar message. I’m pretty new to linux, so unfortunately I have no idea how make works and how to fix this error. Thank you for your patience.

ROOT Version: 6-22-08
Platform: Ubuntu 20.04.2 LTS
Compiler: gcc 9.3.0


The ROOT team provides ready-to-use binary distributions for some systems (see “Download a pre-compiled binary distribution” therein), including various Ubuntu versions, which you just need to download and unpack. For Ubuntu 20.04 / x86_64 / gcc 9.3.0:

https://root.cern/download/?C=M;O=A;P=*[uU][bB][uU][nN][tT][uU]*20*

So, no fiddling with cmake, make, etc? just download and untar?

UPD: it worked, thanks