Make debian failed

Hi fellow Root’ers,

This is a repetition of a report I sent to Roottalk, but didn’t see it posted…

I’ve successfully compiled the source code for ROOT 5.10.00 on a Debian stable system (Pentium 4, kernel 2.6.11, gcc 3.3.5). The ./configure linuxdeb && make cycle went smoothly. I ran it locally before installing and worked well (i.e., the interactive prompt showed up :slight_smile: ). However, I couldn’t make a Debian package in the end.

The commands I used (bash shell) were the following:

wget wget mv html510.tar.gz root_v5.10.00.htmldoc.tar.gz tar zxvf root_v5.10.00.source.tar.gz mv root root-5.10.00 cd root-5.10.00 tar zxvf ../root_v5.10.00.htmldoc.tar.gz ./configure linuxdeb --enable-qt --enable-thread --enable-pythia6 --enable-cern --enable-afs --enable-python --enable-mysql --enable-asimage --enable-astiff --enable-globus --enable-krb5 --enable-ldap --enable-opengl --enable-oracle --enable-pgsql --enable-reflex --enable-rfio --enable-roofit --enable-shadowpw --enable-soversion --enable-shared --enable-ssl --enable-table --enable-xml --enable-xrootd --enable-mathcore --enable-mathmore --enable-minuit2 --enable-clarens --enable-peac make make map make cintdlls

However, after trying to build Debian packages from it with make debian, it failed with the following error (only the last lines are shown):

[code]touch build-arch-cint-stamp

Add here commands to compile the indep part of the package.

#/usr/bin/make doc
touch build-indep-stamp
make[1]: Leaving directory /home/jbatista/ROOT/root-5.10.00' fakeroot debian/rules binary awk: relocation error: awk: symbol _dl_catch_error, version GLIBC_PRIVATE not defined in file with link time reference make[1]: Entering directory/home/jbatista/ROOT/root-5.10.00’
dh_clean -k -s -Xdebian/tmp
dh_clean: I have no package to build
make[1]: *** [install-arch] Error 1
make[1]: Leaving directory `/home/jbatista/ROOT/root-5.10.00’
make: *** [debian] Error 2
Not surprisingly, no *.deb files were created…

I saw some discussion on this subject on previous Roottalk threads, but I’m still confused as to what is the best “recipe” to solve this problem. Is there an updated how-to that I can have a look at to solve this?

Thanks in advance!

After a brief exchange of emails with Christian Holm, he steered me into the right direction: the problem is with awk/gawk. So here’s what I’ve found out:

  1. Perhaps awk/gawk is locale-sensitive (I didn’t bother to look into the Makefile in detail :wink: ). In my system the default locale is LANG=pt_PT@euro. If I use export LANG=en_US gawk seems to give the correct version number.

  2. make debian doesn’t seem to do well with the GNU awk (gawk), so I had to install the original-awk Debian package instead. With this, make debian did well :smiley: .