Macro gets frozen on thread cleanup [Raspberry pi 2]

Hello everyone!
I managed fairly easily to install Root-6.04.16 on my Raspberry pi 2. Regular macros work perfectly, however, not very quickly. So I wanted to use more threads a rpi2 has 4 of them. I took an example of using more threads and I rewrote it into a script I’d like to use. Once I run it on my pc it works well, but on the rpi it gets stuck on

<TPosixThread::Cleanup>: cleanup 0x6ce00478. And this is the first of two threads. The processor then shows no usage, so I am asking, what is it doing or why is it stuck?

Thank you very much for any comments.

(I know that Raspberry isn’t supported platform, but I hope that someone already tried before me :slight_smile: )
threads.C (2.48 KB)

Hi, kecupak!

I have no idea about your problem, but I want take the opportunity to consult you about how to build ROOT 6 on Raspberry Pi. I have failed several times and tried to find the right way on this forum.


If you have 1st generation of RPi, than it does not have enough RAM to compile. Otherwise the code to compile ROOT 6 I found on this forum. Can you please state where you fail?


not exactly what you asked for but here is a previous discussion about compiling ROOT-6 on RPi3:

(I’d recommend to cross-build instead of building on the RPi. actually, I’d recommend to use Go instead of C++ :P)