Macports paths in configure script


Before I start getting into the details, I would like to know if the ROOT team would be open to a diff to the configure script that would allow ROOT to find libs in /opt/local (like fftw3, etc).

If I get a green light, I can start digging into the details.



No problem, mail me the diffs.

Cheers, Fons.

So, I tried to expand the thing a little bit further so that it could use the OpenAFS, by adding it to configure

Checking for libafsauthent ... /Library/OpenAFS/Tools/lib Checking for libafsrpc ... /Library/OpenAFS/Tools/lib Checking for afs/stds.h ... /Library/OpenAFS/Tools/include Checking for afs/kautils.h ... /Library/OpenAFS/Tools/include

but when compiling I got

bin/rmkdepend -R -fauth/src/AFSAuth.d -Y -w 1000 -- -m64 -pipe -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -D_REENTRANT -pthread -D__cplusplus -- auth/src/AFSAuth.cxx g++ -O2 -m64 -pipe -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -D_REENTRANT -pthread -o auth/src/AFSAuth.o -c auth/src/AFSAuth.cxx auth/src/AFSAuth.cxx:27:22: error: afs/stds.h: No such file or directory auth/src/AFSAuth.cxx:28:25: error: afs/kautils.h: No such file or directory auth/src/AFSAuth.cxx:29:25: error: afs/com_err.h: No such file or directory

By looking at Makefile.config

SRPUTILINCDIR  := $(filter-out /usr/include, )

AFSLIB         :=  /Library/OpenAFS/Tools/lib/libafsauthent.a /Library/OpenAFS/Tools/lib/libafsrpc.a
AFSLIBDIR      :=   

BUILDKRB5      := yes

it seems that for some reason AFSINCDIR is not defined.

Bingo! It is not defined in config/

grep AFS config/ AFSLIB := @afslib@ AFSLIBDIR := @afslibdir@

Helas, no success. Sounds like in another incarnation it might be possible:

$ make bin/rmkdepend -R -fauth/src/AFSAuth.d -Y -w 1000 -- -m64 -pipe -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -D_REENTRANT -pthread -I/Library/OpenAFS/Tools/include -D__cplusplus -- auth/src/AFSAuth.cxx g++ -O2 -m64 -pipe -W -Wall -Woverloaded-virtual -fsigned-char -fno-common -Iinclude -D_REENTRANT -pthread -I/Library/OpenAFS/Tools/include -o auth/src/AFSAuth.o -c auth/src/AFSAuth.cxx In file included from /Library/OpenAFS/Tools/include/afs/stds.h:13, from auth/src/AFSAuth.cxx:27: /Library/OpenAFS/Tools/include/afs/param.h:16:2: error: #error Unsupported architecture

I am attaching the svn diff.



ps - *.diff is not an allowed extension for post attachments

Hi again,

The linker seems to not like Macports’s libFFTW:

$ rm lib/libFFTW.* $ make g++ -O2 -m64 -dynamiclib -single_module -undefined dynamic_lookup -install_name /Users/adavid/root/lib/libFFTW.dylib -m64 -o lib/libFFTW.dylib fftw/src/TFFTComplex.o fftw/src/TFFTComplexReal.o fftw/src/TFFTReal.o fftw/src/TFFTRealComplex.o fftw/src/G__FFTW.o -ldl -L/opt/local/lib -lfftw3 ld: warning in /opt/local/lib/libfftw3.a, file is not of required architecture ln -fs libFFTW.dylib lib/ ==> lib/libFFTW.dylib done

Anyone out there that solved this nuisance?