MacOS Monterey


I recently updated my Mac to macOS Monterey (12.3.1) and tried to open root. However, I get the following error message:

warning: no such sysroot directory: ‘/Applications/’

C system headers (glibc/Xcode/Windows SDK) must be installed.

error: entry with relative path at the root level is not discoverable

{ ‘name’: ‘’, ‘type’: ‘directory’,


Error in modulemap.overlay!

I am aware of the fact that questions like this have been asked here before, however their solutions didn’t work for me. I uninstalled Xcode 13.1 and installed Xcode 13 with its CLT. I deinstalled and reinstalled root via home-brew. I still get this error. Any suggestions?

Hi @wfelix ,
and welcome to the ROOT forum! Just to confirm, running xcode-select --install does not help either?


Thanks for the quick answer. Sadly, doing this just gives me an error which tells me that the CLT are already installed. Should I update them (although I think root doesn’t work with the updated versions of Xcode)?

Yes, the latest ROOT version should work on Monterey, we even have an official package for it (you could try using that one instead of the homebrew package).

Unfortunately I am not sure what could cause the errors you are seeing. @henryiii would you know?


How exactly do I install these on a Mac? Sorry, I haven’t done this before


xcode-select --reset
sudo xcodebuild -license

See Setup a New Mac - under “if it ever breaks”. That might help.

1 Like

If you rebuild from source there seems to be an issue discussed here. I was able to build root today with the procedure.

If I do this, I get the following error message:
xcode-select: error: tool ‘xcodebuild’ requires Xcode, but active developer directory ‘/Library/Developer/CommandLineTools’ is a command line tools instance

You need to install Xcode from the Mac App Store for that command to work. If you only have the command line tools, and not full Xcode, I don’t think it works - I’m not sure how to reset the command-line tools without Xcode. Maybe you can uninstall and reinstall? I believe we’ve seen ROOT work with only some warnings produced without Xcode installed, but I’m not sure - usually we’d recommend having Xcode.

There might be a way to use xcode-select --switch <dir>, not sure what dir it needs there, but that might be it. This is what my directory looks like:

ls -la /Applications/                                                                 Tue Apr 19 13:41:56 2022
total 0
drwxr-xr-x  4 root  wheel  128 Apr 11 14:18 ./
drwxr-xr-x  6 root  wheel  192 Apr 11 14:18 ../
drwxr-xr-x  7 root  wheel  224 Apr 11 14:17 MacOSX.sdk/
lrwxr-xr-x  1 root  wheel   10 Mar 14 23:30 MacOSX12.3.sdk@ -> MacOSX.sdk

Interestingly, that’s reversed from what I’d expect, I’d have thought the 12.3 path would have been the real path, and the unversioned path would be the symlink.