Mac OS X 10.4.8 Installation of Root

I am trying to install ROOT 5.10.00 from source on an Intel based Mac running Mac OS X 10.4.8. I am using the directory /Applications/root/root for this installation. I keep previous versions of root in /Applications/root as separate directories (e.g. /Applications/root/root_5.08.00) that way I just have to rename directories in order to switch between versions.

I tried installing Root 5.10.00:

./configure --prefix=/Applications/root/root
make install

make install gives me the following output:

bin/rlibmap -r etc/system.rootmap -l lib/libCore.dylib -d -c base/inc/LinkDef1.h base/inc/LinkDef2.h base/inc/LinkDef3.h cont/inc/LinkDef.h meta/inc/LinkDef.h net/inc/LinkDef.h unix/inc/LinkDef.h clib/inc/LinkDef.h metautils/inc/LinkDef.h
Everything already installed…
pn1180766mac:/Applications/root/root jwouters$

Thus ROOT thinks that it is already installed.

When I run root I get the following error:

pn1180766mac:/Applications/root/root/etc jwouters$ root
rootx xpm error: XpmOpenFailed
Error in : library map empty, no system.rootmap file
found. ROOT not properly installed (run “make install”).

  •                                     *
  •    W E L C O M E  to  R O O T       *
  •                                     *
  • Version 5.10/00 1 March 2006 *
  •                                     *
  • You are welcome to visit our Web site *
  •      [](            *
  •                                     *

Compiled on 14 November 2006 for macosx with thread support.

CINT/ROOT C/C++ Interpreter version 5.16.8, February 9, 2006
Type ? for help. Commands must be C++ statements.

Here ROOT thinks that it has not been installed. If I run:

root-config --libs

It points to:


which is incorrect. It should point to /Applications/root/root/lib

(I actually saw this same problem on Linux when we tried to install root using --prefix. We had to do it multiple times before it installed correctly.)

Does anyone know what is going on?


does /Application/root/root exist (from previous version) when doing “make install”.

– Fons

Yes the /Applications/root/root directory does exist. Actually I unpacked the source tar file for 5.10.00 in /Applications/root which then created the /Applications/root/root directory. Thus I did the make and make install in /Applications/root/root. Is that a problem? Do I need to use separate directories?

Hi Jan,

it is fine to build in /Application/root/root, but no need to use --prefix then. That is only needed if you want to install into a fixed location that is not the build location. Also after that the binary is not relocatable as the path /Application/root/root is hardwired in the binaries. Just configure without --prefix.

Cheers, Fons.