Localhost JSROOT server

Here PR for ROOT THttpServer.
It also includes code examples how it should be used.

Thanks for trying to fix it.

In general, users are not able to modify servers.
We need a solution that “fixes” it on the user side (i.e., in the browser).
It seems that the “CORS Everywhere” plugin (for Firefox) lacks this new “fix”.
You now know what is needed, so maybe you could file a “problem report” there (they may be able to add the required “fix” in the new version).

There are another two points with the “Draw in new tab” …

  1. When a canvas is drawn with multiple pads, I can click “Enlarge pad”. When I open the pad menu again, the “checkmark” on the left side is missing (when I click “Enlarge pad” again, I get the whole canvas back). Note: the “checkmark” does appear when one uses a simple “Draw”.

  2. The new tab is always opened with “nobrowser”. Would it be possible to add a menu item that “restores” it in this tab?

There is one point with “Draw” and “Draw in new tab” … when I click “Enlarge pad” in the canvas itself (i.e., not in a “subpad”), then the whole tab becomes “white” … it seems to me that it doesn’t draw “subpads” in this case (well, the entire “canvas” is a “pad”, too, so I expected that the “pad” and all its “subpads” were drawn).

I am not sure that CORS Everywhere can help to solve the issue. But one can try:

About Enlarge of sub-sub-pads. Logically sub-pads belongs to parent pad.
But graphically they drawn independent from each other on the canvas just in the order they appear in the list of primitives. Enlarge of the sub-pad means enlarge only of that particular graphical element - all child pads will not be affected. Therefore in this example enlarge of second-level subpad c1_1 leads to empty tab.

Did you see half-transparent diamond in the left-upper corner. It toggle browser back.

You mean diamond for browser toggling?
Normally it should not be accessible in enlarged mode.
I will try to suppress it usage - this work only partially and makes problem.

I mean a “checkmark”, like the one to the left of the “Show tooltips” menu entry (try it with the original “Draw” tab where it appears automatically).

It seems to me that going between the “enlarged pad” and the “whole canvas” works o.k. (at least I did not notice problems).

I don’t see it by default … I’ve now tried to move the mouse and indeed, if I position the mouse up-left, I can see three small entries (“toggle…”).
I tried “toggle float browser” and now I don’t know how to “remove” it again. :rofl:

Now I get your point. Yes, it was “tiny” problem showing correct enlarge status of the sub-pad.
Now it is fixed:

Float browser has same buttons in upper-right corner.

Again. nothing was visible by default … but when I moved the mouse there, it appeared (“half-transparent”).
Well, I understand I sometimes need to search left, sometimes right. :upside_down_face:

BTW. At the bottom, on both sides, I can see half-transparent “Toogle tool buttons”. :wink:

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.