Loading libPyROOT in windows


I have just installed ROOT 5.15/08 on win XP and run it and I want to load libPyROOT.
For some reason it doesn’t work and moreover the command prompt ,in which I run root, freezes when saying:

root [0] gSystem->Load(“libPyROOT”);

It doesn’t even say that it couldn’t find in the pathes set in the “path” environment variable.

On the other hand everything works fine if I want to load another lib, e.g.

root [0] gSystem->Load(“libRooFit”);

I don’t know whether it is connected to the problem but I have also Python installed on my XP and I also set the PYTHONPATH and PATH variables according to this page:


So, what can be the problem?



Just try to call gSystem->Load(“libGPad”); or gSystem->Load(“libGui”); before to call gSystem->Load(“libPyROOT”); it should work.
But it is strange, since libPyROOT should not depend on any of these…



in the meantime I downloaded and installed an older version (5.12/00) and it works fine - that is without the error that I got with 5.15/08.
I don’t know whether it is connected with my pc but I haven’t changed any env.var. settings so I guess that it is connected with the 5.15/08 version of root - or maybe I am wrong.




PyROOT required libGpad etc. b/c of dictionary initialization issues on Mac and on Windows. With the improvements in autoloading, that may no longer be the case, but I haven’t checked recently. Just the same, it is explicitly linked with those libraries, so I don’t see why an explicit gSystem->Load would make any difference?

I’m not aware of changes since 5.12. I can, however, make the loading of libPyROOT freeze the console if I run root.exe w/o supplying ‘-b’ on the command line while not having an X server running. But then, so does loading of libGpad …