Linux - root, root.exe, rootn.exe

I am running root on Redhat Linux 9.0. I was trying out the shared memory example and root suggested using rootn.

To the best of my understanding when you type root at the command line it loads root not root.exe. So my questions are:

What is root.exe for in the distribution?
Since I do not have a rootn executable, do I have to build one?


In the same way that you can execute

to execute the version with the shared memory option.


Hi Rene,
Thanks for your reply. Part of the question was to understand why I had both root and root.exe in /usr/local/root/bin but only rootn.exe. This is a curiosity for the most part.

When I run rootn.exe I get the following:

*** Break *** segmentation violation
Generating stack trace…
/usr/bin/addr2line: rootn.exe: No such file or directory
/usr/bin/addr2line: rootn.exe: No such file or directory
/usr/bin/c++filt: unknown demangling style `gnu-new-abi’

which repeats until I kill the process from another window.


Hi Chris,

root launches the reddish splash screen,
then executes root.exe internally.
You can execute root.exe directly.
In particular, to debug a program with gdb, you must do
gdb root.exe
and not
gdb root

Now, why rootn.exe does not work on your system,
I don’t know. On my Redhat 9 system, it runs correctly.
Which version of Root are you running?
Could you try our latest binary tar ball for version 3.10?


Hi Rene,

I ended up trying several things. Let me start by saying that I made the producer of the shared data as a seperate executable, not using root, but the libraries. When I ran rootn.exe I was in the same directory as the executable producing the data. Every variant I tried ended up with the same results.

When I ran the consumer script under rootn from a different directory it worked. I have since run 2 instances of rootn.exe in the same directory without any problems.

For all purposes this is a closed problem. It i curious that my executable causes the problems observed though. More investigation will be done. Thanks for the help.


Did you link your own executable with ?

This is the main difference between root.exe and rootn.exe.


I feel very sheepish and silly. I ended up searching the repository of knowledge and found that this problem has crept up before. Looking at the source for TMapFile Fons had a suggestion that deals with the problem.

The consumer program must be run to find out the ‘preferred’ address space. This then must be used in the producer program.

Why it causes a endless trace in rootn.exe I am not really sure, but I’m not sure it’s worth the effort to hunt down.
Thank you very much for your help.