Linking with

Dear ROOTers,

when linking a standalone executable I got the following linker error:

/products/ROOT/4.00_06a/gcc-2.95.3/root/lib/ undefined reference to `rfio_HsmIf_reqtoput'

I’m using gcc-2.95.3 and root v4.00_06a. I also tried root v4.00_08, but it didn’t help.
I’m not sure about the cern libraries. So far I’m using /cern/2002. Also, I cannot see to which library this symbol belongs (packlib?).

The whole thing worked with root v3.10_03 and /cern/2001.

Can anybody help me?


libRFIO is linked against libshift.a that should be
in your /usr/local/lib/libshift.a (or .so)


Dear René,

I’m working on the Desy AFS cluster. The shift library is nowhere to find on the whole system except in the latest (2002) cernlib directory. Unfortunately this version of doesn’t contain the function in question. I don’t know why.
I solved the problem by download of from and link against it. This works now.
I noticed that in older root versions (eg v3.03_09) was provided with the binary package.