Link error in Mac OS X 10.6.3 ROOT 5.26.00b


I am running Mac OS X 10.6.3 on a new Intel-based Mac computer, and trying to install ROOT v 5.26.00.b from the downloaded tarball.

I have set $ROOTSYS = /cern/root
and $LD_LIBRARY_PATH = /cern/root/lib

When I start the build, it eventually dies with the following link error:

gfortran -O2 -m64 -o bin/g2root main/src/g2root.o
-Llib lib/
/usr/local/lib/gcc/i686-apple-darwin8/4.2.1/…/…/…/x86_64/libgfortran.dylib /usr/local/lib/gcc/i686-apple-darwin8/4.2.1/x86_64/libgfortranbegin.a -lm -Wl,-rpath,@loader_path/…/lib -pthread -ldl
ld: -rpath can only be used when targeting Mac OS X 10.5 or later
collect2: ld returned 1 exit status
make: *** [bin/g2root] Error 1
rm core/utils/src/RStl_tmp.cxx core/utils/src/rootcint_tmp.cxx

I have tried several different versions of ./configure, ./configure macosx , and ./configure macosx64. I also tried ./configure --disable-rpath , and that didn’t seem to make any difference.

Any help would be greatly appreciated!

  • David Asgeirsson


please install the latest version of gfortran from Fink (the one coming with the gcc 4.4 suite). The current one you have is too old to support the new required linking methods.

Cheers, Fons.

You can also download from the following:

  • gfortran-42-5646.pkg (for Xcode 3.2 and 3.2.1) or gfortran-42-5659.pkg (for Xcode 3.2.2)
  • libgfortran-4.2.4-5646.tar.gz (needed for dylib)

This has worked for me on Mac OS X 10.6.3 and Xcode 3.2.2 and has the advantage that you do not need to install fink!


Thanks for the tips!
I actually had Fink already installed, but it was corrupted in the process of moving from 10.4 to 10.6. So I had to fix it anyways. After installing gcc44, I was able to go back to the ROOT directory, make clean, configure and make again. Now it worked!