libXrdSeckrb5.so missing when trying to read from castor

Hello,

From my laptop (Ubuntu 9.10, ROOT 5.25/05) I try to read a file from castor like this:

TFile *file = TFile::Open("root://castoratlas//castor/cern.ch/user/g/gchouda/file.root");
and I get the following errors:

[quote]XrdSec: libXrdSeckrb5.so: cannot open shared object file: No such file or directory opening shared library libXrdSeckrb5.so
XrdSec: libXrdSecssl.so: cannot open shared object file: No such file or directory opening shared library libXrdSecssl.so
XrdSec: No authentication protocols are available.
Error in TXNetSystem::Connect: some severe error occurred while opening the connection at root://castoratlas//castor/cern.ch/user … 00001.root - exit
Error in TXNetSystem::TXNetSystem: fatal error: connection creation failed.
XrdSec: libXrdSeckrb5.so: cannot open shared object file: No such file or directory opening shared library libXrdSeckrb5.so
XrdSec: libXrdSecssl.so: cannot open shared object file: No such file or directory opening shared library libXrdSecssl.so
XrdSec: No authentication protocols are available.
Error in TXNetFile::CreateXClient: open attempt failed on root://castoratlas//castor/cern.ch/user … 00001.root
[/quote]

The same thing from lxplus works fine.

Here is my $ROOTSYS/config.status file:

and I attach also my config.log file just in case.

Side-question please: When we manage to solve this problem, will it be possible to make a TChain like this?:

TChain* chainData = new TChain("qcd",""); chainData->Add("root://castoratlas//castor/cern.ch/user/g/gchouda/*.root");
So far, I tried it too, and I got a similar message, starting with the same complaint about libXrdSeckrb5.so.

Thank you very much,
Georgios
config.log.txt (283 KB)

Dear Georgios,

For some reason the krb5 plug-in did not get build on your laptop.
We need the output of xrootd-configure to get some more hint.
Can you please do the following

$ make distclean-xrootd
$ make all-xrootd > xrd-configure-out.txt

and post xrd-configure-out.txt ?

Could you also specify when you check-out ROOT? 5.25/05 is not a tag and there were several changes in makefiles / config scripts during those days.

Gerri Ganis

Thanks for your quick reply!

I attach the file.

I checked out the code on 2009-12-14.

I tried again, and here is the output:

[quote]Error in TUnixSystem::DynamicPathName: Netx[.so | .sl | .dl | .a | .dll] does not exist in /host/root.5.25.05/lib:/host/root.5.25.05/lib::.:/host/root.5.25.05/lib::/host/root.5.25.05/cint/cint/stl
Error in TUnixSystem::DynamicPathName: Netx[.so | .sl | .dl | .a | .dll] does not exist in /host/root.5.25.05/lib:/host/root.5.25.05/lib::.:/host/root.5.25.05/lib::/host/root.5.25.05/cint/cint/stl[/quote]

Note: “/host/root.5.25.05/” = my $ROOTSYS.

Thanks,
Georgios
xrd-configure-out.txt (113 KB)

Dear Georgios,

Ok, ‘krb5’ is not enabled in your configure.
Please make sure that you have the following packages installed in your Ubuntu installation:

$ sudo aptitude search libkrb53 libkrb5-dev krb5-config krb5-doc
i A krb5-config                                                         - Configuration files for Kerberos Version 5
i   krb5-doc                                                            - Documentation for MIT Kerberos
i   libkrb5-dev                                                         - Headers and development libraries for MIT Kerberos
i   libkrb53                                                            - MIT Kerberos runtime libraries

If something is missing, complete the installation with

$ sudo apt-get install libkrb53 libkrb5-dev krb5-config krb5-doc

Once that done, you should issue

make distclean-xrootd
./configure <...your options...> --with-xrootd-opts="--enable-krb5"
make

Please check that the XROOTD configure says something about kerberos 5, something like

and then that libXrdSeckrb5.so is created and copied under lib:

If any of these steps does not work, please post the related outputs.

Gerri

Hello Gerri,

Here are my steps (as root):

i A krb5-config - Configuration files for Kerberos Version 5
p krb5-doc - Documentation for MIT Kerberos
p libkrb5-dev - Headers and development libraries for MIT[/quote]

Oups… the one missing is “libkrb53”. So, let’s do:

[quote]Reading package lists… Done
Building dependency tree
Reading state information… Done
Package libkrb53 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
krb5-pkinit libkrb5support0 libkrb5-3 libk5crypto3 libgssapi-krb5-2
E: Package libkrb53 has no installation candidate
[/quote]

Aha… so, “libkrb53” is replaced by “libkrb5-3”.
I checked,

and saw that I have “libkrb5-3” installed, so I may be fine.

So, I went on with installation as you indicated. I thought maybe the option --with-xrootd-opts="–enable-krb5" is what I was missing last time.

So, I re-compiled. Here is my config.status:

After the compilation, I ran again the commands

$ make distclean-xrootd $ make all-xrootd > xrd-configure-out.txt
in order to check what you told me, but I saw this:

[quote]Checking for krb5.h … no
Checking for libk5crypto … no
Checking whether we’re using MIT Kerberos … no
Checking for libkrb5 … no
[/quote]

Could it be that the makefile does not understand I have “libkrb5-3”, and expects “libkrb53” instead?

What can I do now please?

Thank you,
Georgios