Libxml2 problem 2.7.1.-9.7.1. (solved)

sorry for disturbing the forum, just before sending this post I solved the problem - so I think this could help to somebody :

on older system I have libxml2-2.7.1-2.fc9.i386 and root 5.20/00
I use libxml to parse config and to compile my application in CINT I make

.L w06.C+

and everything is just perfect.

I installed root v. 5.22/00 in suse 11(?). I installed new libxml2 libxml2-2.7.1-9.7.1. When I do just two steps - loading .so and compiling w06.C+, it complains
Too many ‘}’ /usr/include/libxml/xmlerror.h:912:
Too many ‘}’ /usr/include/libxml/xmlmemory.h:169:
and several other errors in globals.h

once I start over and do all the three steps, it complains the same, but with a path
/usr/include/libxml2/libxml/ - same errors, same lines.

I tried to reinstall root, configure --disable-xml, but no change…

I copied 2.7.1.-2 files xmlerror.h xmlmemory.h from /usr/include/libxml2/libxml/ to the suse directory and what happened? It worked with old include files.